64 bit SDK installer does not complete

I have downloaded the 64 bit installer several times. When I run the installer it will configure the installer, then the installer welcome page comes up. I click next and the installer closes.

I am running Windows 8.1. I have attempting to troubleshoot the compatibility through windows and I get the same result.

I have an older version of the 3.0 sdk installed currently and everytime I attempt to check for updates it fails.

Any help would be greatly appreciated.

Thank you for your time.


Unfortunately our updateservers are down.
Take a look at sdk/reporting_issues.md at master · jMonkeyEngine/sdk · GitHub and see how you can make the installer output Debug Log.

See also Windows x64 installer broken · Issue #79 · jMonkeyEngine/sdk · GitHub (deleting the .jmonkeyplatform-installer folder)

Can confirm that what OP is describing is exactly the same what happened to me when I reported that issue. Now we know that it’s not win7 specific.

I have cleared the .jmonkeyplatform-installer and I can run the installer now, however the extracting process is taking forever. I have let it sit for over an hour and it is only at 10%. I am going to force quit and attempt a new download again. Does anyone have any suggestions? Or is there a new place I can just download the binaries that I can use in my eclipse build?

Did you try the Linked way to produce a Log?
You can also download the zip file, its the platform independent portable Version.

you could.

clone git (with branch/tag you want or pre 3.2 version)

run “./gradlew build”
wait a few minutes and have all the jars in pefectly new condition :slight_smile:

Also possible to download directly from maven repro:

I was able to get it to install, it took almost 2 hours to complete the extraction process.