AARGH! Stupid Error For UNKNOWN reason!

I have this error:

Oct 3, 2006 7:16:59 PM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Exception in thread “Thread-0” java.lang.UnsatisfiedLinkError: getJNIVersion

at org.lwjgl.DefaultSysImplementation.getJNIVersion(Native Method)

at org.lwjgl.Sys.<clinit>(Sys.java:103)

at org.lwjgl.opengl.Display.<clinit>(Display.java:103)

at com.jme.system.lwjgl.LWJGLDisplaySystem.initDisplay(LWJGLDisplaySystem.java:405)

at com.jme.system.lwjgl.LWJGLDisplaySystem.createWindow(LWJGLDisplaySystem.java:135)

at com.jmex.game.StandardGame.initSystem(StandardGame.java:200)

at com.jmex.game.StandardGame.run(StandardGame.java:127)

at java.lang.Thread.run(Unknown Source)

with the code of TestLoadingGameState. WHY?!?!?!?!?!  :’( :’( :cry:

NOTE: I have the needed VM arguments, cuz stuff worked before.

                          -GIBI!!! }:-@ }:-@ }:-@ }:-@ }:-@ :x :x :x :x :x :? :? :? :? :?

Are you sure you're referencing the correct version of LWJGL natives?  Verify they are the same ones that are in the lib directory.

You mean the jars? Yeah, I think so.

Here are the VM arguments: -Djava.library.path=./lib -cp ./lib/lwjgl.jar;./lib/jogg-0.0.5.jar;./lib/jorbis-0.0.12.jar;./target/jme.jar;./target/jme-awt.jar;./target/jme-effects.jar;./target/jme-model.jar;./target/jme-sound.jar;./target/jme-terrain.jar;./target/jmetest.jar;./target/jmetest-data.jar

It doesnt work without the the stuff after  -Djava.library.path=./lib.

Yes, the jars are the same, as far as i can see. And I just updated cvs. (In case I somehow screwed up the source when what looking at it) and it doesnt work. GRRR… Any more ideas except just killing everything and redownloading/installing/setting up jme?

                  -Gibi :’( :// :x :x :x }:-@ :smiley:

EDIT: Suppose I just deleted EVERYTHING that EVER had to with jme on my computer?.. And then reinstalled it with CVS only? (Now, I have no idea what is there, cuz i originally used nightly build jars, and now dled cvs with eclipse) Im thinking of doing that, cuz after a couple hours of hoplessley trying to FORCE it to work, it wont. I give up. Tomorrow, I will reinstall everything with cvs only.

PS. Where are most of the people who develop/use this engine? I’m in Maryland (USA), and after I come home from school people arent there (Mostly, in the morning on weekends and days like monday when i am here)

I've actually seen this before, but I don't remember what caused it or how I fixed it.

Just for kicks try removing the library.path and dropping the DLLs into your JRE's bin directory and see if that makes any difference.

I just had the same problem with Fengui. Never with jme though.

It was caused by jars not corresponding to the apropriate dlls. So you might have lets say 1.0 beta 3 jars and the dlls for beta 2

Try downloading the lwjgl package from thir site and use the jars and the dlls from them.

try downloading the version from lwjgl.org, and updating your lwjgl jars and dlls…