I'd like to suggest changing the method addToUpdateCallbacks(PhysicsUpdateCallback) to addPhysicsCallback and even changing PhysicsUpdateCallback to PhysicsCallback.  Descriptive is good for methods but I think you've gone a little overboard my friend. :wink:

It's really not that big of a deal, just a suggestion.  If nobody else cares then I'm content to leave it as-is.

There are several possible callbacks for physics (on update, on collision, etc.). And you won't want to change the API just because you think the name is a little long, would you?

Well, the main reason I'd like to change it is because I spent more time trying to figure out where to add the callback than I would expect should have been necessary because of the naming.  It's so long that it appears at first glance to be something I shouldn't touch. :o

Wouldn't this be a StepCallback anyway since it's not called every update but every step?

If you really think it's important, add an add-method with a more descriptive name, deprecate the old one and delegate to the new one. But I really think, we can keep the interface name, if nobody else votes for changing.