Alpha 4 - exception on startup and unstable GUI

Hi jMonkeys,

I am running jMonkeyPlatform Alpha 4, with Nightly updates (up until they stopped a few days ago - but that’s another problem, in another thread) - on Ubuntu 10.10

When I launch jMP I get a rude exception:-

Error in scene! (org.lwjgl.LWJGLException: X Error - disp: 0x95b7210 serial: 29 error: BadValue (integer parameter out of range for operation) request_code: 1 minor_code: 0)

And the scene viewer crashes - not too bad because I don’t really need the scene viewer right now, but this exception leaves the jMP gui in a totally unstable state, ie. it now hangs if I try to do something as simple as maximising the code editor window. Argh! Then I have to terminate the process and restart the SDK.

I am running Ubuntu 10.10, GeForce 6800 GS, nVidia drivers 260.19.44 - other OpenGL stuff works great, Compiz works fine (disabling it doesn’t help jMP at all), my app written in jMP runs fine, - and the scene viewer worked ok the first time I installed jMP a few weeks back.

I’ve also tried launching jMP from a command prompt, but that doesn’t change anything.

Here’s what looks to be the relevant section from ~/.jmonkeyplatform/dev/var/log/messages.log

INFO [com.jme3.system.lwjgl.LwjglDisplay]: EDT: Notifying OGL that canvas is visible…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Canvas is now visible! Re-initializing…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Waiting for canvas to become displayable…

INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Creating display…

SEVERE [org.openide.util.Exceptions]

org.lwjgl.LWJGLException: X Error - disp: 0x9016970 serial: 29 error: BadValue (integer parameter out of range for opera

tion) request_code: 1 minor_code: 0

at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(

at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)

at org.lwjgl.opengl.LinuxDisplay.createWindow(

at org.lwjgl.opengl.Display.createWindow(

at org.lwjgl.opengl.Display.create(

at org.lwjgl.opengl.Display.create(

[catch] at com.jme3.system.lwjgl.LwjglCanvas.createContext(

at com.jme3.system.lwjgl.LwjglCanvas.restoreCanvas(

at com.jme3.system.lwjgl.LwjglCanvas.runLoop(



INFO [com.jme3.system.lwjgl.LwjglDisplay]: OGL: Waiting for display to become active…

Diagnostic information

Input arguments:











Compiler: HotSpot Client Compiler

Heap memory usage: initial 24.0MB maximum 494.9MB

Non heap memory usage: initial 278.2MB maximum 310.0MB

Garbage collector: Copy (Collections=48 Total time spent=0s)

Garbage collector: MarkSweepCompact (Collections=4 Total time spent=1s)

Classes: loaded=7456 total loaded=7456 unloaded 0

INFO [org.netbeans.core.ui.warmup.DiagnosticTask]: Total memory 3,434,668,032

INFO [null]: Total physical memory 3,434,668,032

Maybe that helps someone?

Maybe this is already fixed for nightlies in the last few days? – I don’t know, my updates are not completing (see for more details)

Is there anything I can tweak in the conf file to make this problem have less of an impact? Can I disable the scene viewer somehow?

If you need any further info, just let me know!



Yeh, ubuntu is going haywire about jmp at the moment, disabling compitz and updatingthe drivers helps for some but not all.

Thanks for the quick response.

I am running the latest drivers, and disabling Compiz doesn’t fix anything for me.

Is there anything else I can try?

(Also there any news on when the nightly updates will be working again?)



You said you already tried it, but somebody reported he had different results when he ran the jmp executable directly from the bin folder (cd /usr/local/jmonkeyplatform/bin; ./jmonkeyplatform) or something like that.

Thanks - yeah, I’ve already tried that - and unfortunately it didn’t change anything for me: I still get an exception on startup, and an unstable gui. (It didn’t make the nightly updates work either)

I’m thinking it might be an idea to uninstall alpha4 and go back to alpha3 - I just want a working/stable gui again!! And if I have no joy there then I might have to go back to plain old vanilla Netbeans.

Thanks for your suggestions.

You can also do:

svn co jme3

cd jme3

ant run

To get the latest nightly :wink:

Oops, wrong thread

Thanks to your reply on the other thread, I am now running with an up-to-date jMP built from svn.

The good news is that after deleting my settings folder (~/.jmonkeyplatform) and disabling the welcome screen (in Tools->Plugins->Installed), I can now maximise and minimise my code editing window ok again!

Again, thanks for your assistance.

1 Like