Ambient Light not found

Maybe my sdk install is messed up or something.

I want to use the com.jme3.light.AmbientLight class. It’s in the javadoc, but my install of jMonkeyPlatform says it doesn’t exist.

I used to have the alpha 2 version, then I uninstalled it and installed the alpha 3 version.

Still no AmbientLight.

help, please.

Ambient light is not in alpha 3, you have to use the nightly builds to use them.

To activate the nightly updates in JMP go to Tools/plugins menu.

Got to the Setting tab and check the JMonkeyPlatform nightly svn

That didn’t seem to change anything. I had it check every startup, and it says it checked, but my project is still using the same libs. BTW this is a project I haven’t touched since september.

Of course, I don’t know the first thing about using nightly builds.


Ok, solved my problem, I had to go to the updates tab and press “reload catalog”.

Of course that lead to a half of a dozen things that had changed in the api since september.

But now it works, and I can access the AmbientLight class.

Thanks for your help :slight_smile: