Android mobile folder not showing in jme3

Hello everyone. I wanted to give the android app a shot in jme3 as I already have worked with jme3 and found its awesome.

I followed the instructions in both the links here:

At first it worked and it created a folder called mobile. The problem was that it was not running properly. So I update all necessary plugins. After that the problem started. Now the mobile folder does not come any more in jme3 but when I go to the project folder, I see it is there but not being detected. I tried to fix it but no luck. Any idea how to fix this problem?

K Out!

did you install the nbandroid plugin? the “Mobile” folder is considered as a project only if you have this plugin.

Note that it’s not necessary though it will work even if you don’t have this plugin.

Make sure you have the “compile on save” check box in the project properties unchecked.

Yup I have nbandroid installed and the “compile on save” check box is unchecked.

still gives the same problem. This started after I updated the plugins. It was working before that, I mean the mobile folder was showing in jme3 before the updates.

Have you tried creating a brand new project and deploying that to mobile?

That will show you if its a systemic problem or specific to that project.

Yes, I created new project and followed the steps, but the problem is that after build it does not create the .apk it gives an error

"Adding libraries for android.

K:JMEAndroidTestnbprojectmobile-impl.xml:51: Warning: Could not find resource file “K:JMEAndroidTest${}”

And I have also selected the “Android Device”.

I have noticed that once I check the “Enable Android Deployment”, I can not uncheck it. It remains checked every-time I restart jme3. Any idea why that is happening?

fixed the “Enable Android Deployment” check box thing, I had to save after unchecking it, but the other problem still remains the same.

Found the mistake. This is what I did. I unstalled jme3 and started to install and upgrade the plugins one by one. The problem started when I updated “Android Support”. Not sure why but thats the case. Thank you all for your help. :smiley:

K Out!

You probably get an error (small warning sign in the lower right) when you unvheck the box and press ok. Click it and post the stack trace.

normen this is the error I get when I build

1 error; aborting

K:/JME/AndroidTestingnbproject/mobile-impl.xml:13: The following error occurred while executing this line:

K:/Program Files (x86)Android/android-sdk-windowstoolsantbuild.xml:818: The following error occurred while executing this line:

K:/Program Files (x86)Android/android-sdk-windowstoolsantbuild.xml:820: The following error occurred while executing this line:

K:/Program Files (x86)Android/android-sdk-windowstoolsantbuild.xml:832: The following error occurred while executing this line:

I was just trying to make an android app of the default blue box in jme3 but couldn’t.

First of all make sure your Android SDK is up to date. Then update the SDK and all of its plugins including the “Android Support” one (and the “Android” one if you use NBAndroid) to the latest version. Then delete the “mobile” folder of your project manually if you have issues disabling android deployment. After that make sure android disabled in the settings and press OK so the settings are saved. This should give you a “clean” project in android terms. Now you can re-enable android deployment again and it should work.

1 Like

@normen : Dude you are a genius. I did what you told me to and it worked like a charm. Thanks man. Finally i get to make some android apps.

K Out!

I am not able to see mobile folder in my project.It has been developed in the project location but not visible in the project. I have Android plugin installed and the Enable Android deployment enabled but I am unable to get the mobile folder visible in project. Help!!!

Not working… :frowning:

I tend to:

  1. Select “Open project”
  2. Navigate to the main project’s folder.
  3. Select the “mobile” folder (which looks like an android project)

It now shows up as “mobile” in the “Projects” window. Be careful if you have several open, though!

1 Like

Ok so this step was not specified that we needed to do this. Anyways not with this step it is visible. Thanks Rickard