Animated model missing faces

I got one animated model (a palmtree) successfully imported from blender to jme3. However, I have a problem with second model. I took same steps in both models to create animation (+ both model are exported/imported alike).

The second model is a cactus. In jmonkeyplatform the model is missing faces:

If try to export the model without animations (animation checkboxes unchecked from ogre meshes exporter) the model looks ok in jmonkeyplatform:

Any suggestions?

some more info would help to solve this such as:

  • Have you applied all modifiers (did you use any to begin with?)
  • What blender version are you using?
  • What ogre exporter are you using? blender2ogre or the one from the SDK?
  • Do you have a rootBone with no scale/rotation/translation at 0,0,0

    I haven’t really done much animating myself tho, but have you tried converting all polygons to triangles (theres a button in blender somewhere for this)

if you use blender2ogre then it might be the 4 bone problem again. (i had character losing his belly)

before you export it, try to change value at trim weight mine was 0.12 and it worked

or check the inside outside (editmode Ctrl N in blender)

hope it helps

1 Like

Hi, I tried to check suggested issues:

  • The model has only armature modifier, which is needed for animation to work
  • I am using blender 2.62
  • Exporter is blender2ogre 0.5.5
  • Root bone is at 0.0.0 and the rotation in it according to animation. However, unsetting rotation did not have any affect on missing faces.
  • There are 6 bones, having only rotation
  • Setting trim value at 0.12 did not have any affect on missing faces.
  • Normals seem to fine for me (recalculating outside did not have any affect).

    Here is the model. Please see if it has issues preventing proper exporting. Perhaps something I failed to properly check from suggested issues.


there are missing faces when some of vertices dont have bone assigned :wink:

1 Like
@oxplay2 said:
there are missing faces when some of vertices dont have bone assigned ;)

Yeah, i had this problem to, if you go into weight painting mode, if any of your faces are not painted (no bone assigned) they won't show up in JME
1 Like

That was it, making sure that all vertises are assigned to a bone fixed the problem. Thanks!