Animation bobbing around

Hey Monkeys!

I am having trouble going from Blender model to jme3.

I did what is listed in the animation checklist:

Single root bone,
Apply trasnform rotation

But when I load the model, the animation does not run like in blender, it just bobs around aimlessly.

I noticed that the skeleton debugger does not work (null exception) and I get that “more then 4 vertex weights” message.

Here is a link to the model, maybe someone can tell me what I am doing wrong…

Thanks in advance!

Maybe you have inverse kinematic bones, bake those to normal animations.

Hi normen,

I found this post on blender and tried what you said.

It did not make any difference. Does the model link work for you ?

I used standard bvh (if there is such a thing) and manually rigged it to that model. She runs perfectly in blender anyways…

Here is a screenshot of my rig in jme3. Are "A"s and "S"s where they are supposed to be ?

Using the Ogre exporter it works fine.

1 Like

Sweet, she can run !!!

She is all red thow… Did youhave the same problem ? Jme3 can’t load the material file apparently. I tried renaming it but nothing… There are tga’s involved. Any ideas ?

Thanks allot btw

Yes,i had the same problem until i switched to ogre format.Anyway,the material importer doesn’t load textures used in blender as much as i know so i think you should write a .j3m from your own as you’ll probably not want a shadowless model in your final game :slight_smile:

What do you mean by switched to the ogre format ? Did you get the colors right ?

I tried making my own material but since the tga files are for both head and body, I have trouble making it work. I guess I could remap the textures myself but it looks like it would take allot of time. I would prefer not messing around with it too much.

I tried loading the blender file (the textures map properly with a .blend) and using the “generate material” in jme3. I then tried to apply that generated material to the ogre scene and this is what I got:

Is that a mouth on her leg?

I mean exporting the model in ogre format(mesh.xml) and using UV mapping to texture it.

Try y-flipping the texture when you load it.

Oh yes,i forgot about it.Try to use TextureKey and flip Y.

I simply imported it and the textures were fine… I can see what blender settings i have maybe you have to set them too… By the way, you should put all the files ogre exports into a folder inside your assets folder and then simply double click the .scene of ogre. But I will have a look at my blender settings this evening and see if that is the cause .

Okay it definetely has to do with your Blender preferences, as Ogre doesn’t event export the textures. When I reloaded the startup file and opened your file without loading the UI and settings (that’s a checkbox option when loading a file) and exported it it worked fine.

Oh and by the way make sure that you use the latest version of the Ogre exporter

Hey mathiasj!

It worked perfect thank you very much for that link!

Bonus questions:

  1. How can I attach an object to her hand?

  2. Is it possible to make certain part of her move, even if an animation is running?

Eg I want to make her head rotate to look at me when I walk around her even if she has an “idle” animation running.

To only move a part of her, have a look at different animation channels in the wiki if you want two animations at once. Otherwise you would have to change the rotation of the head bone manually and use an animation channel for all the other bones.

To attach a node and move it with the animation you can use an attachment node. Right click on a bone in the scene explorer and click on get attachment node. Now there will be a new node in the file and you can attach your spatials there.

Awsome, thanks!

Hope this thread is as useful to others as it was to me.

BTW, the female character I rigged was from

Here is the animated link again:

If anyone wants to use it to learn how it works, feel free to download and do whatever you want with her :wink: