Animation Loading MD5

I’m new to JME and am trying to load an animation from blender via the MD5 format and the MD5Importer.  The exporter, I used was the der_ton Doom 3 MD5 exporter.  So far everything is working out fine when I load the animation, except it looks a little distorted, as if some of the vertexs don’t have a weight on them and are extremely stretched in the direction of the root bone.  When I check back in blender all my vertexs are weight painted.  I’m stuck, I checked the MD5 and the triangle count doesn’t equal the weight paint count in my .md5mesh file, is this supposed to happen.

Here’s some screen shots:{9978c0d1-8677-4277-9d68-de9f00ba9551}&image=8FFC2656D3B27FF7!207&imagehi=8FFC2656D3B27FF7!205&CID=-8071534277794037769

Nevermind I found the solution, I had too many vertex groups in blender.


I'm currently facing the same problem, and i'm a total Blender-Noob.

I'm used to use 3dsMax for private purposes, but @work there is no 3dsLicence.

So i have to use Blender instead narv

Using 3dsMax everything works fine with the MD5Export…

My model is a human character, consisting of a mesh and a 20 Bones.

Well, so the problem seems to be related to vertexgroups.

I actually don't have used vertexgroups within blender consciously, i only know that there is the possibility to use either vertextgroups or envelopes for the vertexweights by the armature-modifier.

Currently i'm using vertexgroups (was suggested in a tutorial) for the weightpainting, and so a new vertexgroup is created for each bone of the model. I couldn't find a way to prevent this.

If i delete a vertexgroup afterwards, the vertexweights of the animations are deleted as well. I found no way to combine vertexgroups to reduce their number and keep the same animation results…

Can you (or someone else) give me a hint??

Do i have to split the model into several parts, and combine them again after importing them to jme?



I only recently got the time and courage :stuck_out_tongue: to start rigging in blender myself it isn't hard, once u get used to it, I dont use the modifier, I use the old way of parenting the armature, but u should be doing that also, since derton's script doesn't support modifiers, at any rate, I dont use vertex painting, it feels clumsy or rather I feel clumsy using it :|, any how

the vertex groups can be managed from the "F9" button panel "that what I call it", look for "links and materials" panel there u can work with vertex assignments without vertex paint, with mesh selected u should see your vertex groups,

if the mesh was previously attached to another armarture, u need to delete those  old groups unless the names correspond accurately to your present armature. then u parent and choose armature, then "dont create groups" it should use the weights stored in the existing groups

if ur mesh has no groups u can parent choose "create from bone heat", then select ur mesh go to editmode to manage ur vertex assignments, if u have control bones that u dont want directly influencing vertices find them in the drop down list choose "select" to highlight the vertices it influences, then "remove", to get rid of the infuence and finally "delete" so that it will no longer be considered as a VG,u work similarly to fine-tune the rest.

unfortunately I can't elaborate further at work now

I'm not sure if your having the same error I had since the image I posted is offline, but what I did was delete an extra vertex groups that weren't named exactly as the bones I was using.  See, I had created my own custom vertex group to store some vertices, but apparently the der_ton exporter exports this vertex group even if there is no weight values or bone attached to them.  It's not really how many vertex groups you have, it's what they are used for, in your case you should have 20 vertex groups all named the same as your bones.  One other gotcha with MD5 is you have to have a root bone.  Hope this helps.

1st: thank you both for the response!


ok, i got what you mean. And it was the solution… so it was the same error :wink:

I had a vertexgroup which was independent of the bones (and their names)… and this vertexgroup had some vertexweights, which were influencing exactly those vertices which were streched to the rootbone. So it was causing the error. After detaching the vertices and deleting the group everything is fine!


well, yeah, rigging and vertexpainting isn't that hard at all. But in comparison to the workflow in 3dsMax, working in blender sucks imho :wink:

I'm sorry i have to contradict in this case, but using the armature modifier works so far. Using vertexpainting seems to work as well. I'm able to export it as md5 and der_ton's modelviewer as well as the jme based MD5_Viewer are showing correct results after i deleted the needless vertexgroup.

But anyway, i appreciate the efford of taking time to test stuff and write the reply!

keep on coding!