Animation stuck on first frame

I did

    prisonerAnim = prisonerModel.getControl(AnimControl.class).createChannel();

which I believe worked for me before, but the animation is stuck on the first frame. Is this a problem with blender or what?
Anyone else encounter this problem before?

EDIT: I should also note that this model is a rigidBody that is moving around.

It should work.
Does the animation plays in the SDK?

Hey friend; when I run the game, the character just stuck on the first frame of the animation. When I don’t use this code, the character is in his original T-pose.

Also, I edited my original post

Yes but, can you play the animation when you open the model in the SDK?

See in this shot, double clicking the Idle animation in the anim controller plays it in the scene viewer


Oh, okay. Well when I play the animation in the Scene Composer, the character stays in his first animation frame. I feel like I am doing the same steps as I usually do when using animations. Is there a problem with using animations that are longer than 400 seconds?

Actually, I think it might work if I convert from a .blend to a j3o instead of a .scene to a j3o, but now the problem is, apparently jmonkey doesn’t support Inverse Kinimatics? :frowning:

Not perfectly some of them work, but I think not all cases.

1 Like

erm, now that I am trying to use blender files as a base to convert to j3o,

this line:

prisonerAnim = prisonerModel.getControl(AnimControl.class).createChannel();

gives me a NullPointerException. This is peculiar, because when I open the j3o in the SceneComposer, I can play the animations.

Make sure the Control is really on the prisonerModel itself and not a sub node.