Now I have a scene with an animation - its flowing lava, it just does one cycle then repeats itself in blender, and its called Plane.003Action (I need to name stuff correctly, I know…). I set up everything the same as it is in the beginner animation tutorial, only using my scene instead of an actual character, but I get a null pointer exception when trying to load control.addListener(this);

I’ve never really worked with animations before which is why I’m testing it out now and I really cant see what I’m overlooking here.

Quick link to the tutorial

No, it is just a flat quad with a lava texture on moving forwards and then resetting it’s position in a loop.

Hm, ok. Just seems a bit pointless to me… anyhow

you tried to make this via Shape Keys?

it is impossible, you need skeleton animations.

developers done a great work, but yes, i miss Shape Keys too :frowning:

This is because you don’t get an AnimControl returned, hence you try to call addListener on null… Open the model in the SceneComposer and look in the SceneExplorer where the actual AnimControl is and if its exported at all.

I can’t find it, I guess that means that it hasn’t exported? How do you export it?

Tried all that but nothing is working, must it have an armature?


@javagame said:
Tried all that but nothing is working, must it have an armature?

if you import through he ogre workflow yes. Only Bone animation is supported.
I think the blender importer, import spatial animations (spatial transformation), but none of them import mesh deformations without armature.
And actually this feature is not supported in the engine itself ATM.
1 Like