Animations are extremely distorted when imported into JME

So, I’ve downloaded a pair of arms that are rigged with bone constraints, now if you were to animate just the arms, then the animation would import just fine, but if I added another object (Like a gun) to the scene and attach that to the skeleton in blender and animate, then when I export the model 2 either to things will happen.

If the arms and the object are individual meshes.
Then the animation of the arms reloading (just an example) will be split into what the arms do, and what the gun does. and also the arm’s texture will be extremely distorted

If the arms and the object are the same mesh:
Then the animation will not work.

So far, I have.

  • Applied, Scale, Rotation and Translation for the Bones (once before animating)
  • Baked the Pose Animations (Options that were ticked were: Visual Animation, and Pose)
  • Set all rotations as Quaternion.

And it still comes back distorted.

How can I fix this and make the animations work?

Right and the Pair of Arms that I am using is this file:,

I also modified a few things like, I removed the Mirror Modifier and I keyed all the animations with Rotation, Scale and Translate

did you apply them on the model itself too?

Hmm… I don’t remember but I think I was just in object mode and pressed a and then applied everything

I think it might be because of the IK animations or something.

are you importing them with the blender loader?
If so, yeah IK support is partial in the loader, so if you have IK, you should use ogre exporter.

I think I fixed it,
All I had to do was tick remove constraints

ha nice ! thanks for the heads up

Wait actually the test animations worked, but if I use a real animations, it tells me “mesh has vertices with more than 4 weights applied, the model might now behave correctly” is there any way I can get rid of this error without revisiting the model?

Those are just warning, there is no way to get rid of them, but they may not have any visible effect.

Hmm… Can I send you the blend file that I am working with then?
I don’t know how to fix it…

If you send me the blend file, I could try to import it trough xbuf exporter/importer, if you like.

(It might take a while though, I’m just about to call it a night)

If I remember correct, JME limits amount of bones that influence single vertex for performance reasons. Blender don’t have that limitation so you could end up with model where all vertexes are influenced by all bones with different weights.

What happens when you import such a model - exceeding bones are ignored when calculating bone influence so result may be different compared to blender. But if it was minor influence then you’ll hardly notice a difference.

Ok, Here is the Blender model than I am experimenting with (None of the Models were mine, only the animations, The link to the hands are above, the link the Kalash(

(Blender Model)

I posted the blend file on the thread, would you mind looking at it for me. (also what is this mystical xbuf import/export that you speak of, and where can I get one)

If only there were some magic internet answer machine… :wink:

;-; I got rekt

1 Like

Sorry for late reply. I was off main of the WE and a bit busy today (I would like to made a ultra basic game for Ludum Dare #34, this evening). I’ll give a try to your blend file ASAP.

Alright thanks man, but I think I figured out something, I think this might be an error in blender when I baked the animation it apparently removes all the constraints on the bones but for some reason the shoot Animation came out all right. Can I just dig my animation with visual keyframes?