AnimControl player.getControl(AnimControl.class) returns null

Hello all, I was following the Animation Workflow Tutorial fron the hello Assets tutorial. There it calls getControl on the player who is an AnimControl and passes AnimControl.class as an argument. This is returning null, which forces an exception in the next line of code. Now, I did use this code before an it worked… but when I tried to change the mesh and the animation, now it returns null. I was wondering under what circumstances it returns null, so I can correct that on the mesh and animation.

In case it matters, Im working on motion capture files BVH, and I just added a cube to the head bone, and tried to export that with OGRE XML.

The OGRE exporter reported no errors or warnings, and when I converted the XML to jme binary, I also had no problems whatsoever.

Thanks a lot


Update: I tried to do the export, this time with the mesh parented and the armature and it worked.

Hello dgrandes,

I am having the same problem you describe here!

What do you mean by “with the mesh parented”? Where did you do that?


i am having the same issue. anyone?

The problem was solved for me! From what I understand the problem appears when you import a model without a skeleton. As soon as I added a skeleton in the model (actually only a single joint as the object that I imported is just a sphere) the problem disappeared!

Could you elaborate a bit about adding a skeleton? I have my model skinned and rigged with an animation and channels setup. I am not sure how I should add a skeleton exactly. Does it have something to do with the parenting of the mesh to the armature?

Well I followed this very very detailed tutorial ( in order to import my model in JME. Note that I worked my model in Maya so this tutorial only covers the workflow from Maya to JME (in fact the JME import part is not covered by the tutorial but it should be very easy: Just convert the produced files (i.e. the .mesh and the .skeleton files) using the OgreXMLConverter ( and then place the .mesh.xml and .skeleton.xml files into the assets/Models/ folder of your JME project (don’t forget the .material file as well). That should work (well it worked for me!).

Hey thanks for the quick reply. I think I got it now.