Another "no lwjgl in java.library.path " Topic as it seens

OK. I’m totally new to JME. all what i know about Java comes from my first and second semesters at University and Goggle. so all i can do is very basic things and all the complicated stuff have been always automatically made by either JCreator or Netbeans, all i can do by now is a simple program that organizes some DVDs on a list and do stuff for a friend of mine(all Graphical Interface have been made by Netbeans…)

So i decided to start my dream and make a game, since i understand a LOT more of Java than C++ i decided to try it in Java (Note that “a LOT more” is still not “a LOT”). Then i found JME. I though to myself “Whoa, kool graphix, gotta learn how to use it”, and for that i read the Getting Started topic: seens that there are a lot of “Getting started” topics, so i decide that might be important to say which one i read.

Then i followed step by step that thing (oh yeah, since the one for Netbeans 6.1 is in progress, i used the one for 5.0 on Netbeans 6.1) and then decided to get started and read the tutorials. then i copy-pasted the code from Copiled, and then Runned…

Netbeans says and then laugh at me:“no lwjgl in java.library.path”

I tough: “ZOMG WUTFUK, I’m almost sure i followed that step by step perfectly…”, then i got into the forums and searched for “no lwjgl in java.library.path” and found 9 pages of topics about that. started to ready some… and found out that i don’t understand a single word of the mumbojumbo you guys says about “classpath” and “Native stuff”.

Right now I’m downloading Netbeans 6.5 and hoping that by explaining my situation i will get a easier to understand solution to this problem.

Thx in advance!

Best to avoid the older instructions as they may no longer be applicable - I know the tutorial at works just fine as I have used it (with NetBeans 6.5) in the last few days.

ClassPath = (at its simplest) java’s equivalent to the windows path. Its where it will look for .class and jar files. You really should find out more about this before going any further as it lies at the core of java.

NativeLibrary = a library not written in java. Usually this will be something like a device driver (which is pretty much impossible to write in java due to lack of pointers etc) or a library which needs to use the speed of another language. Not that important to know tooo much about these, but

thx, i will try this rightnow

It quite of worked now!!

when i tried to run the little program from:

Netbeans returns me a error:



Compiling 1 source file to C:JavaGuedes’ ProjectsGuedez Gamebuildclasses

C:JavaGuedes’ ProjectsGuedez cannot find symbol

symbol  : variable ALWAYS_SHOW_PROPS_DIALOG

location: class


1 error


You are trying to use a JME1.0 tutorial with JME2.0.

2 options here,

Use the JME2 tutorials

or modify the code of the tutorial you are using based on the contents of :-  (good practice :slight_smile: )

now it's working fine! thx