Anyone else get really scrappy performance on Linux?

Hi forums!

After returning to jmonkey after a while, I have discovered one of my old problems is still here - but worse!

I cannot start a new project anymore without a crash :frowning: I’m on Ubuntu 12.04, I also had problems on Arch.



I already program in java, so I can be sure it is not a JDK problem, but anyway, here is my java -version:

[java]java version “1.6.0_24”

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-1ubuntu0.12.04.1)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)[/java]



Maybe this is a probloem with OpenJDK? If another has this problem I will consider installing sun’s version instead.



Thanks,

Gary.



(And developers, this isn’t a dig at you at all! :smiley: Obviously these problems stem from a highly skilled ninja-infiltrator sneaking into your website and replacing shell scripts with shopping lists)

1 Like

I develop on Ubuntu 12.04 myself.

OpenJDK 6 aswell as OpenJDK 7 work flawless for me.

I would suggest removing the .jmonkeyplatform directory and letting it reconfigure itself, but you say you had the prob on 2 Operating Systems.



I have a dual GPU system that can be a little messy with X.org (very rare problem, but it can happen).



Which error do you get? does it simply close on you?

Perhaps you can get more info when you start jmonkeyplatform from the command line.

I just get random crashes. But, after removing that directory it dosn’t seem to crash so often. At least I know that the problems arn’t just occuring on my system and config. Thanks for your time! :slight_smile:

1 Like

I’ve had that too, Oracle JDK helps and going to 1.7.0_u7 has helped. Actually it hasn’t crashed for a while now that I think about it :slight_smile:

netbeans is written in java so when you run it from the terminal you should see the exception, if it is one.



If you have bad luck the problem lies within GPU drivers, X.org etc.



Maybe you want to go into jmonkeyplatform settings and go into the OpenGL Tab.

There you can switch to OpenGL 1. Perhaps its an OpenGL Problem.