ArrayIndexOutOfBoundsException when creating collisionshape

i’ve just updated JMP, and i now have got this error:

[patch]java.lang.ArrayIndexOutOfBoundsException: 1

at com.bulletphysics.collision.shapes.QuantizedBvhNodes.setQuantizedAabbMax(

at com.bulletphysics.collision.shapes.QuantizedBvhNodes.setQuantizedAabbMax(

at com.bulletphysics.collision.shapes.OptimizedBvh.setInternalNodeAabbMax(

at com.bulletphysics.collision.shapes.OptimizedBvh.buildTree(


at com.bulletphysics.collision.shapes.BvhTriangleMeshShape.<init>(

at com.bulletphysics.collision.shapes.BvhTriangleMeshShape.<init>(

at com.jme3.bullet.collision.shapes.MeshCollisionShape.createShape(

at com.jme3.bullet.collision.shapes.MeshCollisionShape.createCollisionMesh(

at com.jme3.bullet.collision.shapes.MeshCollisionShape.<init>(

at com.jme3.bullet.util.CollisionShapeFactory.createSingleMeshShape(

at com.jme3.bullet.util.CollisionShapeFactory.createCompoundShape(

at com.jme3.bullet.util.CollisionShapeFactory.createCompoundShape(

at com.jme3.bullet.util.CollisionShapeFactory.createMeshCompoundShape(

at com.jme3.bullet.util.CollisionShapeFactory.createMeshShape(

at mygame.Main.simpleInitApp(


at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(



according to this the error should be at line 113 of the simpleInitApp method, and this is the line of code:[java]com.jme3.bullet.collision.shapes.CollisionShape sceneShape =[/java]and this contains no array.

before the update, it worked correctely. what should i do to make it work again?

Oh, @Momoko_Fan also had problems with this error message :smiley: Since which build build does that happen? Did you update the day before?

i updated today, and it didn’t happen before.

How should i solve it?

I mean, did you update before? Were you already using the nightlies? You will have to checkout a version that works for you and use that (see jMP Manual about “using a custom jme3 version”) or go back to alpha-3 if you were using that before.

i update every day, and with the version of yesterday, it worked. Maybe it’ll work again when i update tomorrow.

I committed a fix for this problem and run a build right now, however I don’t know if the change of @Momoko_Fan I reverted was needed for something else:

i updated again, and now it works.

thanks normen