Asset import error. Used to work

Hey I used jME a few months ago with Blender and I could import models but I decided to start up a game again but I can’t import models.

This is the error I get in the jMe import manager when I try and import a model

[xml]Error in scene!

(java.lang.NoSuchMethodError: com.jme3.gde.core.assets.ProjectAssetManager$DummyProject.<init>(Lcom/jme3/gde/core/assets/ProjectAssetManager;Lcom/jme3/gde/core/assets/ProjectAssetManager;Lorg/openide/filesystems/FileObject;)V)[/xml]

I first tried it with a model that had a material with one texture and I got that error and then I tried it with a basic circle with no material on it (just the circle.mesh.xml) and got the same error.

I export the object from Blender with the ogre exporter and the xml file looks fine.

Any ideas would be great thanks.

Did you use the nightly version at some point? Do you have all stable updates installed? Did you change the blender version?

What do you mean by the nightly version? Well since the last time it worked Ive formatted my computer. jMonkey and Blender are fully updated.

When I import the object in the actual code in the simpleInitApp() function I get piles of warnings but the thing that stops it is this severe error:

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]


at com.jme3.scene.plugins.ogre.MeshLoader.applyMaterial(

at com.jme3.scene.plugins.ogre.MeshLoader.startSubMesh(

at com.jme3.scene.plugins.ogre.MeshLoader.startElement(












at com.jme3.scene.plugins.ogre.MeshLoader.load(

at com.jme3.asset.DesktopAssetManager.loadAsset(

at com.jme3.asset.DesktopAssetManager.loadModel(

at com.jme3.asset.DesktopAssetManager.loadModel(

at mygame.Main.simpleInitApp(


at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(



The window then closes.

SDK → Tools → plugins → Settings → JME SDK Nightly

and update.

Nononono! Don’t use nightly, its causing issues, not solving them… So you say you use the latest version of blender? Rather use 2.62.

oh, my fail, i thought that you want him to try nightly :stuck_out_tongue:

sometimes i should really shut up :roll:


after thinking about that, btw: i never tried(in blender) to add a material slot to model and do not apply material to that slot.

but it could be issue too.

theres a reason its broke :slight_smile:

cough normen cough

@wezrule said:
theres a reason its broke :)

*cough* normen *cough*


nothing :slight_smile: <3

@wezrule said:
nothing ^_^ <3

My problem is that I predict breaking stuff all the time but nobody listens ;)
1 Like

Ive just downloaded the blender 2.61 there and now when I try and export from it with the ogre exporter it creates a material file and gives an error and no mesh.xml file.

The ogre exporter that comes with the engine (Tools->OgreXML) should work with 2.61