Asset Not Found Exception

Ok so its been a few weeks since ive run my project, been working on some utility classes. But my test case, which i haven’ t touched, is now throwing an asset not found exception on a texture i was using for grass. The file exists, is in the correct directory that the asset manager is looking, and yet i keep getting the trace. Any thoughts?

We’d need some information to help. Anything would do… name of the file on disk. Directory it’s in. Line that’s loading it. Stack trace. Any or all of the above would be helpful.

Sorry, i know better than to post without such things, just slipped my mind lol

the file is Grass512_low.jpg located in the Textures folder of Project Assets.

[java] Material mat_terrain = new Material(assetManager, “Common/MatDefs/Terrain/Terrain.j3md”);
Texture grass = assetManager.loadTexture(“Textures/Grass512_low.jpg”);
mat_terrain.setTexture(“Tex1”, grass);
mat_terrain.setFloat(“Tex1Scale”, 64f); [/java]

tried to force it to wireframe to check to see if it still works otherwise and found that my skybox textures arent working either.
application works fine with those removed as well.

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main] com.jme3.asset.AssetNotFoundException: Textures/Grass512_low.jpg (Flipped) (Mipmapped) at com.jme3.asset.DesktopAssetManager.loadAsset( at com.jme3.asset.DesktopAssetManager.loadTexture( at com.jme3.asset.DesktopAssetManager.loadTexture( at armageddon.procedural.Genesis.inTheBeginning( at armageddon.procedural.Genesis.gen( at armageddon.Main.simpleInitApp( at at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread( at at

And if you look in the project directory, underneath it there is a directory:

or was it renamed somewhere?

Also, before I go assuming things… this is in the SDK and it’s a JME BasicGame project, yes?

assets/Textures is correct
and yes this was started as that. Like i said this was running a week or so ago, and i havnt touched anything since. Ive been busy writing an ES for it, which is in no way tied into this module yet. Just suddenly it stopped finding my resources. :frowning:

Still no joy?

Hmm weird, is that the first custom resource being loaded?

Other things to try:

  • Check the assets.jar in the dist folder and see if it contains the file
  • Create a new project, put that asset file in there, and try to load the Texture, see if you get the same issue.
  • A clean + build

Clean Build worked this time. I could have sworn i tried that before tho. Oh well, thanks its working again.