Asset not found; using jme3 beta ide; runs in ide, but doesn't run from build

As I stated in the title, running my jar file will result in an assetnotfoundexception. running the project in the ide works fine, but the built jar file does not find the file.

You probably try to load an ogrexml or obj file directly, they are excluded from the distribution as you are expected to use j3o files. This is mentioned in the manual under “deployment”.

ah, i see. i just removed the excludes and it works now. thanks

Okay, note that we don’t recommend to use j3o files to annoy you, in the long run they will probably be the best solution, you can easily also batch-convert models in the SDK.

how come? are they easy to read? faster load time?


that’s doesn’t answer my question. that doesn’t state why its better to use j3o files.

Yes the wiki does answer your questions:

Amount of work the code must do to load a .j3o file:


Amount of work the code must do to load a .blend file:


Roughly. :slight_smile:

still doesn’t really explain why its more optimized, but sure, wtvr.

Dude. j3o is a binary file. Everything is binary, is optimized. This is like comparing a compiled java project (e.g.: mygame.jar) with a non compiled java project (e.g: /mygame). Besides fast it’s optimized.

Actually, that’s a pretty good comparison. In this case, .blend is like a bunch of .java files. .j3o is a compiled project’s jar.

…which do you think is faster to get into executable form? :slight_smile: