Asset Problem

Hello All,



I am not really sure if I am posting this to the correct area, or even forum, so please bare with me, I am not entirely sure where to post this.



What Im trying to do:

Import a 3ds file to Blender and export it as an Ogre mesh file, and have the associated skeleton files and material files, and whatever other files I need. (not entirely sure what all I need, its a simple model with a simple skeleton and simple animations and simple materials)



I am having trouble getting the Ogre XML exporter to work properly. I have installed blender and downloaded the ogre xml exporter files (from the zip) and copy/pasted them into the correct (specified) folder. I then installed python both the newest and the recommended version. I also created an environment variable: PYTHONPATH and set it to: C:PYTHON22DLLS



When I installed python I installed it to the standard place.



I seem to be able to import the file properly, the problem I am running into is the export part. I am getting the error: “You need a full Python installation to perform this action” and all Im doing is hitting export->Ogre Mesh

(I thought I had a full python installation)



Thanks for any help,

~David

in jME3 platform under tools there is an option to install Blender OgreXML. It will ask where to put your files, the place you probably want them to be put in is “%APPDATA%/Blender Foundation/Blender/.blender/scripts”



(i guess backslashes don’t show up on this forum so that’s why those are forward)

I am guessing that it is a plugin, in which case the closest thing I can find is:

“Blender Support” which when I try to install that plugin, tells me that:

jMonkeyPlatformCore is requested in version >= 0.11 but is only in 0.10.0.6219.45 was found



I figured that there would be a jMonkeyPlatformCore update available in the update section, is there a way to manually force an update aside from uninstalling and then reinstalling JMonkey from the site? I have alot of files and settings that I would prefer not to have to move around, and go through resetting and figuring it all out again. (mostly things like jar files added in, file paths included as well as all of the code that I’ve written).



I thought I had installed the latest version of JMonkey about a month or so ago.



Thanks for any help/support, this pipeline is just the hardest thing for me to get right.

~David

To use the blender importer you have to update to the latest nightly (see Manual-F1). But rivensky means the OgreXML export script for blender that you can install via Tools->OgreXML (as stated in the Manual - section importin Models - too)

Yes, I had issues with the Ogre Meshes Exporter before too, having downloaded a zip and manually installed the first time, so I instead tried to use the exporter installer through the jME3 tools menu, and after choosing the right scripts folder it fixed my issue at the time.



Also I had other separate troubles until I clicked “Help” on the Ogre Meshes Exporter window in Blender, it took me to a website where there are screen shots of what blender options are supported by the exporter. I had something checked that shouldn’t have been, and fixing that solved another problem of mine.



Just a couple pointers, don’t know if it applies to your issue specifically.

1 Like

Hi Guys,



So its I cant seem to find this “Manual” or “Manual F-1” and under tools, there are no options or options that lead to options that says anything about OgreXML, I feel like I must be doing something completely daft, or accidentally working with an ancient version of it. I just checked the version and it says JMonkeyPlatform Alpha v3



I tried using Help->update which tells me to check my internet connection, which is working quite well, I am able to access the internet, ftp, ssh etc etc.



Thanks for any more pointers,

~David

When you press F1 you see the Manual of jMP:





Install the OgreXML exporter for blender through the menu item “Tools”:

What is the “correct” script folder to install into. When choosing to install ogreXML, it is asknig for a script folder (would rather not fall into the folly rivensky did).



Thanks,

~David

the scripts folder inside your blender folder

Hi,



Thanks for everything, I am actually running vista and the script folder is in some crazy place…

C:UsersAppDataRoamingBlender FoundationBlender.blenderscripts



now to figure out how in the world to use the exporter. When creating a model is there anything in particular that are severe no no’s that I should avoid like the plague?



P.S. I tried to export a model I downloaded for free from turbo squid and I cant find where it exported it to, I specified the folder, but everytime I hit “select”, it set the folder back to C:/ and then I couldnt find it in either the C:/ or the folder I specified.



I did get a bunch of warnings during the export though. TONS of warnings, but I didnt see any failure output. (how do I scroll through the log faster, it scrolls silly slow).



Thanks,

~David

Press help inside the exporter and read the manual on how and what you can export.