Assetpack browser doesn't work


When I click ‘online assetpacks’ on the browser menu, nothing happens at all.

When I try to upload an assetpack (attempted to see if its some connection error), I got this:

“Error connecting to!

Server returned HTTP response code:403 for URL:

I did end up getting some assetpacks from, but just wondering for future reference.

Hm, alright.

I’ve downloaded the worldForge asset pack straight from the second link above and tried opening it up in my projects (tried dropping the asset pack in to the asset area of my project along with the XML provided, also tried setting it as a project library).

However every time I try to add an object to a scene it says its material should be in the same folder - I’m guessing the XML needs to be linked in some way?

Also is there anyway to add jme3_test library objects to a scene? when I right click them it doesn’t provide any options really.

I don’t exactly know, somehow the whole java stack seems to try and avoid the server… :confused: Also cannot link to online web pages in the manual…

1 Like

You don’t put the asset pack to a projects assets folder… you put it in home/.jmonkeyplatform/assetpacks

Getting the test data objects is described in the “Hello Assets” tutorial. To modify the assets or just keep some of them, copy & paste from the “Library” node to the “Project Assets” node when you added the jme3-test-data library, then remove the jme3-test-data library afterwards.

Cheers - I managed to get the WorldForge pack to work but a lot of the plants don’t appear in the asset pack browser for some reason.

Which plants?

All I get under plants:

While in the folder directory I do see a lot more.

Their model file format are supported by AssetPack?

Supported formats for models are:

Wavefront OBJ
jMonkeyEngine3 j3o

Question is what you see in the folder and if it is compatible to the loader at the moment :slight_smile: What you see is actual models with correct material references. There is for example other material settings etc. that the assetpack does not provide yet because the mapping must be done manually using a file from the amber client which uses the world forge models.

I fixed the issue with the downloads not listing in the AssetPackBrowser as well as the online help.


I’m getting a “Error in assetpack, could not load assetpack.xml!” in the console after trying to search for “stone_felsite9” a known model from the WorldForge asset pack that I downloaded via the browser. Nothing is showing up in the browser at all. I know that stone_felsite9 is in there because I can open WorldForge in the open project command. I can’t use the pack from the projects tab either because it doesn’t give an option to copy, paste, or add to SceneComposer.

You can copy an item to the project or SceneComposer, right-click it in the AssetPack browser. From all you say I only get few information… Did you use the integrated download functionality in the AssetPackBrowser to install the AssetPack (online assetpacks button)? After the asset pack has been downloaded, you might have to press the “update” button in the AssetPackBrowser to update the contents. You cannot just download WorldForge, you have to use the AssetPack as it contains the necessary metadata to load the WorldForge models.

Got it thanks. Had to restart Java Monkey Platform.