ATI Radeon X1200 - Fragment shader(s) failed to link

This is the error that the linker produces when the class or any other JME based software that uses light sources is ran on a computer equipped with an ATI Radeon X1200 graphics card with any driver version, any OpenGL version, and any JME version. This problem has plagued JME and other OpenGL based software since this popular graphics chipset came out. So far, the JME developers have failed to fix this problem. Although I could personally buy myself a computer that does not have this graphics chipset, thousands of computers still in use still use it. Therefore, I feel that everyone should be wary of using JME in any distributed software, because it WILL cause support problems. Do you plan to fix this problem?

OK, it does SOMETIMES work. I compiled and ran the example and IT WORKS! the light source turns on, illuminating the sphere, and it doesn’t crash with the fragment shader link exception! My apologies for not trying more examples, but I am very surprised that the more complex example worked where the simpler one failed. Not what you usually expect. I will compare the two files and report a fix for the class for us ATI Radeon X1200 users.

When i remove the following line from, the fragment shaders link exception goes away:

86: rootNode.attachChild(ninja);

I think that this exception occurs when a light source is applied to an model from a mesh xml file on a computer with a radeon x1200 video chipset. I’ll try loading different mesh xml objects to see if it is just the ninja or all mesh xml objects.

@kaiservadar said:
So far, the JME developers have failed to fix this problem.

Its a problem of the card and its drivers, did you post a similarly nice email to the manufacturer? I guess not, why bother a big company with lots of money to fix the products they sell? Rather go to people who put out software for free in their spare time and _demand_ they solve your problems! Thats the way! Also stop bumping your own post, you can edit the main post as long as nobody answers (and given your tone I guess you can talk to yourself for long here).

OK, I’ll edit the main post when there are no replies from now on. I realized that the problem was much more easily worked-around and I didn’t want anyone wasting time because I overstated the problem. Just trying to contribute rather than complain, as you have justly requested of me.

The big manufacturer? Reply? heh heh tried that before. I never get anywhere.

In fact, I’m so used to being ignored I figured that noone would pay me any attention here. I erroneously figured that JME was some thing owned by some big rich group of people that employed a bunch of overpaid developers and would probably start putting up advertising and make a bunch of money off of JME somehow in the near future. I didn’t figure that there were actually a bunch of volunteer developers genuinely giving away their work out of the kindness of their hearts. I understand that I insulted you. My apologies. Keep up the good work.


We’ll take that as a compliment then :wink:

Please don’T get this wrong, but where are they using x1200 chips nowadays still, isn’t that somewhere around 2005 so more than 6 years ago. In computer and especially games&grafics thats quite a long time.

Yes, it’s getting old but there are many well built computers like mine still klunking along with that chipset, so it still is nice to guarantee some compatibility for us po’ folks. she’s an old girl but she’s not that slow and has a banging 17" LCD built in. Top of the class a few years ago, and I got a great deal on it.