Attempting to Compile SDK -- 401 Unauthorized -- SOLVED

I’ve downloaded the SDK master zip and am attempting to compile on Windows 10.


  1. Download as zip
  2. Extract to folder
  3. Using Git Shell I run build_engine and fix_engine (both show success)
  4. Run Gradew.bat

I receive the following errors regarding jbullet even though the does show success for that section and I do have the jbullet.jar

* Where:
Build file 'C:\Users\Bob\Desktop\JME Master\sdk-master\build.gradle' line: 357

* What went wrong:
A problem occurred evaluating root project 'sdk-master'.
> Could not resolve all files for configuration ':optlibs'.
   > Could not resolve org.jmonkeyengine:jme3-jbullet:3.3.0-SNAPSHOT.
     Required by:
         project :
      > Could not resolve org.jmonkeyengine:jme3-jbullet:3.3.0-SNAPSHOT.
         > Could not parse POM C:\Users\Bob\.m2\repository\org\jmonkeyengine\jme3-jbullet\3.3.0-SNAPSHOT\jme3-jbullet-3.3.0-SNAPSHOT.pom
            > Unable to resolve version for dependency 'jbullet:jbullet:jar'
      > Could not resolve org.jmonkeyengine:jme3-jbullet:3.3.0-SNAPSHOT.
         > Unable to load Maven meta-data from
            > Could not get resource ''.
               > Could not GET ''. Received status code 401 from server: Unauthorized

Any help would be appreciated, thank you.

Solved. The POM located in the maven repository folder did not have a version set for jbullet or stackalloc.

Thank you.


Had the same issue some time ago actually. Might want to open an issue on the sdk repo.

1 Like