Bad Datagram type

Is this for adding ‘nulls’ ? if not: what did i do wrong ?

(the app crashed shortly after)



[java]

INFO: Child (null) attached to this node (DebugShapeNode)

Sep 8, 2011 10:43:23 AM com.jme3.scene.Node attachChild

INFO: Child (null) attached to this node (DebugShapeNode)

Camera Position: (-142.62524, 28.664822, 106.6044)

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorTypeCheck: CGSDispatchDatagramsFromStream : Bad datagram type 50331648

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorIllegalArgument: CGSGetPortStreamData

Camera Rotation: (-0.019332338, -0.690194, -0.018453246, 0.72313064)

Camera Direction: (-0.9974874, 0.053432252, 0.046516955)

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorRangeCheck: CGSDispatchDatagramsFromStream : Preposterous datagram length 926941440

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorIllegalArgument: CGSGetPortStreamData

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorTypeCheck: CGSDispatchDatagramsFromStream : Bad datagram type 83886080

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorIllegalArgument: CGSGetPortStreamData

Thu Sep 8 10:47:51 Ghuenhwyvar.local java[10185] <Error>: kCGErrorTypeCheck: CGSDispatchDatagramsFromStream : Bad datagram type 8416068

[/java]

Its the name of your geometries thats null.

But is it the cause of the hang/crash ?



(also this is strange, because i have picking in there, and it does show names correctly)

Maybee someone spamming you with junk datagrams? that could cause unknown datagram stuff if im not mistake

it’s all me, single player,localhost ,so whatever goes wrong, the fault is mine or the engine’s, i’ll assume mine