Been trying to use BaseGame with key bindings

Can anyone else try this and tell me if there is a problem?



If I run the FlagRush Lesson 2 code from the CVS copy of jme, all is well and the ESCAPE key exits the demo. However, if I copy the class to a new project which has all the JAR's for version 0.9, the Key Binding just doesn't want to work.



I've started fleshing out a BaseGame structure for my Arcade Cabinet menuing system and have wasted a day because I think there are differences between CVS and 0.9. I want to use 0.9 as it is the last formal release. So what is wrong? Did something change between 0.9 and the CVS version that I'm not aware of?



Regards



Sp33dy



P.S. The documentation really needs working on in places… Ie the tutorials…

As a follow up. I've just created a new package in my copy of the CVS version and then put my new class in there. The KeyBinding is definately working ok in that version, but isn't in v0.9… I really need someone to point me in the right direction. As a newbie, I'm guessing something has been deprecated and I'm not sure what between 0.9 and the latest cvs edition.

The input system has changed significantly in CVS. The FlagRush tutorial series is a work in progress that's focused on upcoming the 0.10 release (it's kept up to date with CVS). I wouldn't know the exact differences, but maybe someone who worked enough with both can tell you that.

You can read about changes from 0.9 to current CVS here. But there is no tut/doc for backporting from CVS to 0.9.



For examples on how to use key bindings and input stuff in 0.9 see the examples coming with that release. You can check out version 0.9 from cvs by specifying tag v09 (-r v09).