Beginner problems on JME-Physics tutorial

Hi I am trying to build the sources for JME-Physics 2 using the tutorial but keep getting this problem

import org.lwjgl.LWJGLException;

import org.lwjgl.opengl.Display;

import org.lwjgl.opengl.DisplayMode;

symbol not found

The paths are added and I have tried updating the file version it still keeps giving me this error

Vista x64 Netbeans 6.0.1


Oh, I didn't notice that, thanks Core-Dump. Your posts were quite confusing, Nekoni, sorry. A correct specification of the error message would have been:

"The constructor in 'LWJGLPropertiesDialog dialog = new LWJGLPropertiesDialog( properties, logo );' is marked with 'Symbol not found'"

I've readded the ctors to the core. jME Physics 2 should build fine again without the patch.

There are no such lines in jME Physics 2. These are from jME core, most probably. Make sure to follow the jME setup tut, first.


I have gone through the first tutorial and build and executed the JME tutorial, it worked fine, the JME-Physics_2 library throws the following error…

LWJGLPropertiesDialog dialog = new LWJGLPropertiesDialog( properties, logo );

        dialog.setVisible( false );

        dialog.setModal( true ); (Symbol not found)

Clicking on the source highlights the following in red…

import org.lwjgl.LWJGLException;

import org.lwjgl.opengl.Display;

import org.lwjgl.opengl.DisplayMode; (Symbol not found)

The settings for jME-Physics_2 are as follows in netbeans:

Sources folders… jme-Physicssrc,jme-Physicstest,jme-physicstest-interactive,jme-physicstutorial, jme-physicsimplodesrc

Libraries Compile… JME-Compile (as per the first tutorial)

Libraries Run… JME-Run (as per the tutorial)

VM Options… -Djava.library.path=G:XatroxProjectsWeb3DJMEjmelib;G:XatroxProjectsWeb3DJMEPhysicsjmephysicsimplodelib

I have tried adding lwjgl libraries direct to this project and in the CLASSPATH environment variable, I am at a loss as to what is wrong, I haven't programmed Java for some time although I have about 5 years of C++ experience and about 2 years of Java experience.


maybe this is because LWJGLPropertiesDialog() got a 3rd Parameter just recently.

there's the patch:

Hi thanks, it's built fine this time around!


I will post a full error next time, I thought it would have been sufficient, sorry - I did post a full error report in another thread but I got no response so I reposted labelling the post beginner (the former post was removed by me), anyway all is working now after applying the diff/patch.

Thanks for the help.