Beta1 demo now available in the Market

A new demo apk is now available from the Android Market:

Name is: jMonkeyEngine 3 Android Tests

Please help us testing and try it. It would also be great if you could post your phone&android version info and the FPS you get at the different demos.

Use Google Goggles for a direct download:

Thanks @EmpirePhoenix for this cool QR


Awesome, ill definitely try it out, in 1-2 weeks once I get my new android phone :P.

Phone: LG Optimus 2x (Android 2.2.2)

SimpleTexturedTest: 873 FPS

TestSkyLoading: 699 FPS

TestBumpModel: 67 FPS

TestNormalMapping: 85 FPS

TestMovingParticle: 81 FPS

TestMotionPath: 31 FPS

TestSimpleWater: N/A

1 Like

Can I get a link for APK file? Not a googleMarket. Just a link to download.

Android 2.3.4 - Galaxy S I9000

INFO/OGLESShaderRenderer(3086): INFO OGLESShaderRenderer 5:44:09 PM use_VBO [false] → [false]

INFO/OGLESShaderRenderer(3086): INFO OGLESShaderRenderer 5:44:09 PM verboseLogging [false] → [false]

INFO/OGLESShaderRenderer(3086): Vendor: Imagination Technologies

INFO/OGLESShaderRenderer(3086): Renderer: PowerVR SGX 540

INFO/OGLESShaderRenderer(3086): Version: OpenGL ES 2.0

For each test I’m getting a : WARN/OGLESShaderRenderer(3086): glError 1280

SimpleTexturedTest: 50-60 FPS

Result : OK

01 simpletexturedtest

TestSkyLoading: 50-60 FPS

Result : KO

02 testskyloading

TestBumpModel: 50-60 FPS

Result : KO (Very poor light)

03 testbumpmodel

TestNormalMapping: 50-60 FPS

Result : OK

04 testnormalmapping

TestMovingParticle: 30-40 FPS

Result : KO (Black)


TestMotionPath: 20-25 FPS

Result : OK

06 testmotionpath

TestSimpleWater: N/A

Result : KO

07 testsimplewater




Samsung Galaxy S II

SimpleTexturedTest: 60 FPS - vsync on?

TestSkyLoading: 700 FPS

TestBumpModel: 69 FPS

TestNormalMapping: 70 FPS

TestMovingParticle: 70 FPS

TestMotionPath: 55 FPS

TestSimpleWater: N/A - working with 3 black boxes on the screen


I have just a black screen with default settings.

When selecting “Use VA instead of VBO” I can see something…

HTC Desire (no HD)

helloEffects does not show anything (tried both options).

Can’t find any information about FPS. Where are those hidden?

1 Like

Huawei Sonic U8650 - cheapest 2.2 I could find!! (is really 2.3.3)


SimpleTexturedTest: 33 (Note: I wrote this demo for myself and was getting 44 - go figure!)


TestBumpModel: 40

TestNormalMapping: 55

TestMovingParticle: 35

TestAmbient: 60

TestMotionPath: 8

TestSimpleWater: - can’t see FPS and my image looked like dherby’s

Can we have the source code to this please so we can see launching one activity from another? Thanks.

Cheers Jonathan

1 Like

HTC Desire HD, overclocked with htc dhd revolution ROM 5.2.2 (android 2.3.3)


Simple Texture Test 55

Test Sky Loading 55…

Test Bump Model 49-50

Test Normal Mapping 50-60 (jumpin up and down)

Test Moving Particle Total freeze, had to remove battery. tried twise

Test Ambient 400-600

Motion Path 70, working fine, but there is no teapot… just camera following invisible target

Simple water: working, but very messy black and white picture of squares, where there is in the middle of jme3 box that i can move.

1 Like

HTC Nexus 1 android 2.3.4

SimpleTexture : OK ~45 fps

TestSkyLoading : OK ~34 fps

TestBumpModel : OK 12 fps

TestNormalMapping : OK 18 fps

TestMovingParticle : OK ~25 fps

TestAmbient : OK 62 fps

TestMotionPath : KO : Cannot render mesh without shader bound (must be an error in the shader)

TestSimpleWater : Same as f4ntti


Thanks for feedback guys!

How it should look like:




1 Like


You are using the older demo, name in the market of the new one is “jMonkeyEngine 3 Android Tests”


Thanks for info, could be a Android 2.3 issue. Need to get a 2.3 device hands on :slight_smile:

larynx said:
Thanks for info, could be a Android 2.3 issue. Need to get a 2.3 device hands on :)

I couldn't get a proper log, all android is giving me is a timeout error of some sort.

Im currently working on an update with more logging options.

Edit: 20.08.2011 - Market update

Two options are now available EGL Config: [Fastest, Best, Legacy]

and Logging: [Normal, Verbose]

Please try your not working demos with all egl configs.

If its not working, it would be great if you could post some logcat which you think could be important.

This is awesome larynx. I think you’ll find we’ll get a considerably greater amount of testers once we make a blog post about this great new development.

Can you please change the apps name to “jMonkeyEngine 3 Android Tests”. Beta 1 is not tagged and released yet, so we should be careful not to confuse people.

I’m surprised no one has mentioned the download size, he he. Took me quite a while to download the app. It definitely needs some downsizing.

In some tests the FPS could almost double if I let it run for an extended period of time, but I’ll post the average FPS of about 10-20 seconds of running every test.

Samsung Nexus S

Android 2.3.4

SimpleTexture : 50-60 fps - worked

TestSkyLoading : ~55 fps - worked

TestBumpModel :35-60 fps - Only saw the stone foundation, not the wooden part. Scene was very dark.

TestNormalMapping : 45-70 fps - worked

TestMovingParticle : 20-45 fps - Couldn’t see anything

TestAmbient : 50-60 fps - worked

TestMotionPath : 20-25 - worked (teapot showed up and moved along just fine. hadn’t seen this test before, it’s fun!)

TestSimpleWater : failed as expected (pretty colors!)


Done: app name is now jMonkeyEngine 3 Android Tests


Strange i can’t find the app on the market, the only one i can find is the old one made by Anthon.

Did you remove it?

Here is a screenshot of the mapping test, both bump and normal mapping look the same - and wrong :wink:

Device: Galaxy S II on android 2.3.5 CM7

quite huge logcat of this test:

1 Like