Beta1 Stable Libraries and Sources

Hi all!

This may be a dumb question, but I can’t seem to find the jME3 libraries alone in the download section.

I am developing in eclipse and I would like to use the stable beta1 release libraries along with their source code. Where can I find this?

I did try to use the ones bundled in jME SDK (in jmonkeyplatform/jmonkeyplatform/libs), but the sources package does not contain the sources for jMonkeyEngine3-android.jar (or I haven’t been able to find them). Still, I would like to know whether there’s actually a place where I could download the libs and sources alone (without the SDK).

Just checkout branches/3.0beta and build that, after release there’ll be an osgi plugin for the library.

1 Like

Could you please help me with this error message?


jMonkeyEngine-beta1/sdk/build.xml:7: The following error occurred while executing this line:

jMonkeyEngine-beta1/sdk/nbproject/build-impl.xml:41: Cannot find NetBeans build harness.

Check that nbplatform.default.netbeans.dest.dir and nbplatform.default.harness.dir are defined.

On a developer machine these are normally defined in ${}=${netbeans.user}/

but for automated builds you should pass these properties to Ant explicitly.


I got it while running “ant build” from MonkeyEngine-beta1/sdk

By the way: I can’t put a backslash in a post here.

I told you to checkout branches/3.0beta and build that, not branches/3.0beta/sdk :roll:

Nevermind. I guess I had to first build the engine and then the root.

No, you just run ant in root, it does everything

That’s what I did first, but it gave me an error. Then I built /engine and tried again and it worked.

I checked it out again, ran ant build from root and everything worked fine :slight_smile: Sorry about that :slight_smile: It made dist and build folders in sdk, nothing in the root folder.

Still, I can’t find the sources for the android jme3 jar. When debugging, if I link to the sources zip, it finds the correct files (well, the files with the correct name), but the debugger is tracing through the wrong lines. I’m sure this means that the jar is not using the same source. If I link to the engine/src/android folder, eclipse doesn’t find anything (because the package names are not the same).

Just build it and then get the libraries from /engine/dist/, its all described in the wiki…