BetterCharacterControl and physics native

When using the native bullet the jump method of the BetterCharacterControl does nothing. I think because
onGround is false, even when standing on the ground. When using the “normal” bullet it works. Is this issue

Whats known is that the native bullet wrapper isn’t done or stable :slight_smile:

Yep, but I guess its easier to make it stable when people are reporting the issues:) I think this should
be quite easy to reproduce. Maybe its some basic issue with the raytest…

However, this issue is far from urgent…

Btw. When continously jumping you get higher the first 3 times - but i guess this is intended

Not really intended no. Its because the collision check is reporting ground contact in two checks. I want to debounce the jump check over a few frames so you cannot jump twice in too short a time.

Ah, I get it - so 1xjumpforce for every ground contact. I think this “debounce jump check” would be a good settings, because most users wont want to have the character jump that high. Though I must admit its real fun, feeling a little bit like a monkey XD

Its more like in one frame you apply a force and if in the next frame the character isn’t off the ground yet its applied again.