Black outline on transparent node

Transparent texture image is set on quad with BlendState, it shows black outline

(The original image doesn’t have it.)

When it is run by test code, it works

But on other code, it has black outline.

I tested it with png and dds, but got same result.

Anybody has some clue?

help will be appreciated. XD

and check your image file compression and texture compression

"Renderer.QUEUE_TRANSPARENT" fix it!

Thanks a lot.  XD XD XD

Okay, here's one for you. I have the same type of problem but in jME 1, and it does not have BlendState. What is the fix in this case?

The other weird thing about this is the two quads are facing the camera and orbiting each other. The orbits eclipse every half cycle. The transparency works fine when one of the quads is in front of the other, but not the other way round. Is this a ZOrder problem?

As said above, Spatial.setRenderQueueMode() solved my problem.

And texture filtering option (MagnificationFilter, MinificationFilter) somewhat affects to the 'black outline' phenomenon to me.

in jme 1.0 the BlendState is called AlphaState, but works similar. Furthermore, to solve your ordering problem, just set a ZBufferState to the rootNode of your scenegraph.