Black Screen


So for a little over a month I’ve been working on a game in JME, and today when I woke up to start working on it, I got a black screen instead of the GUI that I had just been working on. I thought it was strange, as it worked the previous night. The project still works on Android, but doesn’t work on the PC. I went as far as to reinstall Windows on my computer, and still I see a black screen. Now, even after I’ve installed Windows + JME, I don’t even see the damn blue box when I make a BasicGame. Does anyone have any clue as to why JME would just stop working overnight? This has been driving me crazy all day!

Did your display drivers update in the middle of the night?

Something must have changed. You just need to figure out what.

See, the strange thing is, I’ve tried running the simple BasicGame program on two different machines, one a PC the other a Mac, with all of everything completely updated. Fresh install of JME on the mac, fresh install of Windows 7 and JME on the PC, and I can’t get the blue cube to show on either of them. The only machine that is working is my desktop that hasn’t been connected to the internet… Is anyone else experiencing these problems? It seems strange that the two machines that don’t work are completely up to date…

Do other opengl applications work? (eg unigine heaven benchmark can run in opengl mode)

Yep, other OpenGL applications work… everything seems to work except for JME. Which is really frustrating.

Well, I got it working on another machine with fresh installs of everything. It’s probably a problem relating to the OS or the drivers, I kept getting a strange “Nvidia display has detected a problem with OpenGL driver” message whenever I’d try installing a different driver… Thanks for the suggestions, though.