Black terrain editor

Hello everyone. I have gone through the tutorials but I am having nothing but trouble with the Terrain Editor. Sometimes I see the terrain but most of the time it is completely black. If i close JMonkey and re-open i see the green arrow but it is still a black screen. What am I doing wrong? It seems so random. once in a blue it works. Is my camera losing the scene, is there a reset to get the camera back to the default position in the editor?

I have the Lightbulb clicked and even added a directional light to the scene.

Thanks for the help.

I may have figured it out and I think it is definitely a camera issue on my part. I think it has to do with the button that has Front, Back, Left, Right , Top and Bottom options. When i click top i see the flat terrain via overhead view otherwise i dont see anything. Is there a recenter button that automatically puts my view in the editor to the middle of the scene or origin?

Can i make it so the terrain i add is the floor and I cant scroll through it? That might make it easier for me to use.

I think i need to spend some time learning the UI and how the mouse navigates the scene. I find it hard to get the perspective where i want it.



snap cursor to zero… and camer to cursor… combos well with…
The front, back, left, right, top, and bottom … to kind of center things…
yeah… the documentation isn’t “super organized” on the wiki, yet… so…

Here’s a video! :laughing:

but yeah, the major repository of this info is at:

or you can just hit the “wiki” button at the top.

And then… read, read, read… and when you are ready… play! :smiley:

Game On,


Awesome thanks, that helped me out a lot.