Blender 2.63 jmonkey3 exporting to Ogre

Hi everyone,

I’m new to jmonkey3 and i’m trying to any model in .blender or .3ds format,

for that we use Blender to export the model to OgreXML and then the import

function of jmonkey3. This is what i’ve done so far.

  1. Install jmonkey3 and Blender 2.63
  2. in jmonkey go to tools → OgreXML → Install blender OgreXML
  3. Load any model. i’ve tried more than 30 from different open sources
  4. Export the model using the script.

    Result: a .scene file with 2kb of information for the camera, no meshes, no textures

    no error, no anything.

    There are some tutorials but they correspond to older versions of the ogre script and blender

    because the screenshots shown don’t appear anywhere on blender

    After some reading i downloaded the latest Blender2Ogre script, installed the OgreCommandLineTools

    And repeated the same with the all the models i have. And again a scene file with only the camera info (even when disabling it

    from the export menu)

    So far i’ve found no more up to date tutorials or documentation on exporting to OgreXML

    *Note: Yes i also tried loading directly the .blender files and only one would show on the preview screen and no errors.

    Im using windows 7 x64.

    Any leads are greatly apreciated

The latest Blender2Ogre comes with a test model to export. Even with that i’m getting errors

this time at least one error is shown.

AtributteError: ‘Mesh’ Object has no attribute ‘faces’

I’m clearly missing something basic …

I think I got that error twice before

it is a big black pop up error in top links in blender with a lot of text, right ?

I followed this and “somehow” it is solved

I use linux not win so i am not sure,

If I remember well then you need to install

ogre tool solved it may be ogre meshy too.

After installing them and restarting my computer it works. In first time I just need ogre tool. Ogre meshy is installed in second time and is broken, but exporter still work.

here is the note I made for myself in second time

Install Blender2Ogre:

-download 557 preview1 , install + activate in blender

remember to remove 577 after each try in blender

-install ogre tools: apt-get install ogre-tools

-Ogremeshy via Wine ?

Things to check before exporting in blender

-Bone: Ctrl N in edit mode in view axis

-Model: apply loc,rot,scale - Ctrl A in object mode

hope it helps

Hi everyone,

I’m also new to jME3 and I’m having a problem with exporting blender models to ogre using Blender 2.63 on Windows 7 x64.

What I have done so far was:

  1. Install jmonkey3 and Blender 2.63
  2. in jmonkey go to tools → OgreXML → Install blender OgreXML ( to the addons folder of Blender’s scripts folder
  3. in Blender I enable the Ogre Exporter from the User Preferences
  4. export a simple cube model (the one when your start blender) as “Ogre3D (.scene and .mesh)”

    Then blender prompt an Error when I click ‘Export Ogre’, and this is what it showed me:

    I noticed the warning on the addon that says “Quick Start: ‘.mesh’ output requires OgreCommandLineTools ( - install to default path.”

    Then I refer to this page and downloaded Ogre Command-line Tools (1.7.2) and I’m not so sure about the “install” part when it is just a folder and it contains no hint of an installer inside so I just transfer the whole folder to C:\ and changed the name OgreCommandLineTools

    After that I tried to export and nothing changed!

    What Am I missing?

    Thank you for your time!

Download this addon for exporting to Ogre:

blender 2.63 works only with blender2ogre 0.57.

Thanks for your reply, mifth.

I downloaded the addon you suggested and installed it to my blender 2.63 and tried to export the default cube model and still it shows the same error I posted above.

Is the problem associated with the OgreCommandLineTools? How do I know if it’s “installed” properly?

Thank you for your time!

Try using Blender 2.62 if you can help it, if I recall I ran into a similar issue and couldn’t get it to work properly. You shouldn’t need Python installed anymore. Also when exporting from blender to Orge it is important that you have the model selected that you want exported.


Yes, I have installed a Python 2.7.3

Is there a successful version of Blender that works with Ogre? I would use that as an alternative. It seems the 2.63 isn’t gonna work?

Thanks for the reply, JohnBaker. I’ll try to download 2.62. Is jME3’s Ogre script compatible with blender 2.62?

Success! I can export the default cube using Blender 2.62 and import it to jME3.

Thanks a ton, JohnBaker!

Finally made it to export with blender 2.63 and Blender2Ogre

What i did:

  • Install Blender 2.63
  • Install OgreCommandLineTools following the readme included with Blender2Ogre
  • Opened Blender and selected the whole model (Ctrl + MouseClick to select it)
  • Exporting without changing any options.

    And i got the following (the model is named knight.blender)
  • Cube.008.mesh
  • Cube.008.mesh.xml
  • Cube.008.skeleton
  • Cube.008.skeleton.xml
  • knight_0.material
  • knight_0.scene

    I tried importing all of these files one by one, which one is the file i should import on JME3?

    i imported the .scene file and the JME3 complained that

    Cube.008.material doesnt exist, which is true … but i dont know a way to generate it.

    Of course i’m doing something wrong here, but i have no more remedy to just ask because there is no single

    tutorial, help or something … if i can import the model i’ll do the tutorial myself, hahahahaha

    Thanks for any help!

Check these links:


@KennethCaesarOpjer you need python 3.2 or higher.

I’m using Blender 2.69 on Ubuntu 13.10, and I’m getting the following message when I try to export my model.

All that it exports is a .mesh.xml and a .material, but no .skeleton.
Do I need to install something, or what am I doing wrong?

Something is wrong in your model.
I already got this, the error is far from explicit, but mine was due to a bone marked as deformable that had no vertex linked to deform.
If you have IK control bones make sure that you uncheck the “deform” flag in the bone control panel, then when you export in ogre check the “only deformable bones” option.
It can be anything related to the skeleton really…

Thanks, I checked my IK Control bones and unchecked “deform”, but I still got the same results. Do you have any other suggestions as to what it could be?