Blender 2.8!


#1

Have any one seen what happend to new blender ? It has tons of options , new texture/material options and lots more .
But what i would to know is , are all of them possible here ?
I seen some texture function that seems to change body form ,like making it transparent in a part
digging holes … It scares ,couse if i make a model with that stuff i could just be forced to drop it ,if it dont work here !!
And any one alse is bothered with that interface changes as me ?


#2

I personally like the new interface changes. As for feature support. We have great support for glTF, but it all comes down to what format you export your blender model in. Some formats JME3 supports a lot of features, other have minimal support.

I personally have a lot of problems and crashes with 2.80, so I mostly still use 2.7x. But the glTF support in 2.80 is great.


#3

I downloaded it yesterday to test some gltf exporter features. (I also found a few issues and reported them on gltf-blender-io addon page.)
Have not played with it much, but I like the new interface.
Also the rendering result in EEVEE seems to be closer to result of JME PBR rendering.


#4

I cannot import FBX files into 2.80, it breaks all the bone positions. My 2.80 also does not render materials, everything is just grey. I have tested it on 3 different machines.


#5

Been using 2.8 for about half a year now and apart from ocassional crashes and some features not working in eevee here and there, I must say it’s awesome.


#6

i tried new blender 1-2 months ago.

it changed UI very much, and had a lot options. just need to get used to it.

but, Also a lot options were missing, and can read on blender forums they were still implementing old functions.

now idk if everything is ok, but i think it need more time anyway.

about 2.8, i had one issue with animations that cant be linear(and jme need them linear(idk if with new animation system from 3.3 too)), even if blender have them as linear.

dont know if you tested it, but i remember i had issue importing animations from 2.8 and new gltf plugin for 2.8


#7

Interesting, I have not had this issue… I have not done a lot with animations other than morph animations though with the Blender 2.80.


#8

morph is something different from bone animations, but im glad it work, because i dont tested it.

all i know bone animations using new gltf blender plugin and 2.8 blender had issue with linear animation function so JME crash telling that animation is not LINEAR. While using old plugin and blender animations in exported file are LINEAR always and it works in JME.

in this issue i even provided simple file and show in old plugin its linear(even if blender animation functions are not linear :smiley:) and in new otherwise, its always cubicspline…

this could be solved in JME too, im not sure if new animation system support cubicspline or treat .gltf cubicspline as linear anyway that could fix it. (anyway true issue is in plugin)

there might be a tmp solution changing txt file manually and set a linear, but i dont test it.(because if blender have animations set as linear, then plugin probably just wrong interpret it, nothing more so changing txt value would solve it)


#9

@oxplay2 just tested your example blend you submitted for the issue.
You need to do ( T -> Linear) or (tab Key -> Interpolation Mode -> Linear) while selected all keyframes in Graph Editor, this will make them to use LINEAR interpolation.

 "name" : "CubeAction",
            "samplers" : [
                {
                    "input" : 6,
                    "interpolation" : "LINEAR",
                    "output" : 7
                },
                {
                    "input" : 6,
                    "interpolation" : "LINEAR",
                    "output" : 8
                },
                {
                    "input" : 6,
                    "interpolation" : "LINEAR",
                    "output" : 9
                }
            ]

#10

Have you set shading mode to LookDev mode


#11

Eh… why did everything go from colored to monotone icons? Not a fan personally, hope they add back locking transforms, I assume they’re just wip. Moved select vertices/edges/faces further away from center of screen, nice.


#12

You can use the 1, 2 and 3 buttons on the keyboard to select vertices, edges and faces respectively. The GUI buttons are further away, but overall it’s an improvement.


#13

thats exactly what i did and i had cubicspline. are you sure you use 2.8? or maybe they already fixed it or you got older plugin version.


#14

I replaced glTF-Blender-IO plugin coming by default with blender 2.8 with glTF-Blender-IO master branch.


#15

maybe they already fixed it in other issue then. (or maybe it was blender issue)

my issue was reported in december ;p


#16

But in your issue you mentioned you are using (shift -> e -> Linear extrapolation). That is something different.


#17

hmm… anyway blender changed it to linear (no curves) in graph.

i dont remember now. i might provide 2.79 shortkey for change it.

in old blender you use T key too?


#18

i see, there is little difference in graph when doing it via T key


#19

Yes.
Note:
(shift -> e) is for setting Extrapolation Mode
(T) is for setting Interpolation Mode


#20

oh, ok got it, then my fail.

so just older gltf plugin had issue because there always was LINEAR.

edit: i updated ticket with message based on what you said

so now im probably able to use 2.8 and new plugin with no blockade :smiley:

thanks


JUST NOTE FOR MONKEYS(that use gltf, and probably other formats too):

if JME will throw issue about Interpolation mode(linear required)

in blender 2.8 and glTF-Blender-IO plugin, do like above. it is Set T -> Linear in animation action graph editor, then export to gltf and should work fine with animations in JME. (shift - e linear options will NOT fix it)