Blender Animation doesnt work like it should


First of all: Great project, great work you guys did!

I’m playing around with jMonkeyEngine for a couple of days now and I cant get a Blender animation work like it should work.

It is a realy easy two-boned animation, here is the file:

The only animation is called “Jump”. In Blender the Blobby becomes flat (as it is sopposed to) but in jMonkey it becomes streched up.

I tried all “how to create models properly”-tipps. The only issue I had ist, that in Blender 2.67+ the second “Envelopes”-checkbox is not there anymore!?

Thank you!

Please follow this tutorial: Animations in Blender 2.61 and JME3 - YouTube

I got it from this page

I looked at your file and you are doing it wrong. Please just look at the tutorial and you should be good to go.

Thank you! I realy forgot the part with the NLA-Editor, which makes the node structure in my model cleaner. But apart from this I dont see what I’m doing wrong. I should have mentioned that I tried to use the blender-importer of jME 3.0. The ORGE-exported files crash my jME-IDE; but as far as my research goes this won’t happen with an older version of blender (and the exporter). I will try it this way!

But just to mention: My jump animation uses bone scaling. I added another animation (“Slide”) which only uses rotation/translation and the blender-importer of jME 3.0 handles it fine (in the same model file!). So my conclusion is that either I did something wrong in the “Jump” animation or perhaps there is some issue with animation relying on scaling bones in the blender importer?

Here is the second file:

The “Slide” animation works well with the blender importer, but the “Jump” animation is screwed up.