Blender: File-Change updater ignores removed animations

The automatic updating (popup in jMonkeyPlatform) did not update the removed animations.
RIghtclicking the .blend file in jMonkeyPlatform and generating the .j3o again worked flawlessly.

Removing the actions in Blender in the dope sheet is the correct way to remove an animation.

Original Post:


I use the awesome Blender->jMonkey Importer.

I believed to have removed the animations in my .blend file (cleared all NLA tracks, cleared animation data from the object), but jMonkey still finds my 2 animations “walk” and “idle”.

What must I delete so that an animation is properly “gone”?

  • Removed all NLA Tracks
  • Removed the Actions (dopesheet is empty)
  • cleared animation data from object and scene in hierarchy view

I’ve googled around and also searched these forums, but couldn’t find a solution. :frowning:

Hm… You sure you edit/import the same file?

It was a problem with the auto-update of .blend files in jMonkeyPlatform.

I edited my post with the workaround.

Is there a way to disable this auto-update for .blend files?
It is a little annoying when I model and have jmp open :smile:

Ah. Yeah, updating animations is a feature that hasn’t been added yet.