Blender materials are without MipMaps

Hi @Kaelthas !

It seems blender models are loaded without MipMaps.

Here is my test:
http://i.imgur.com/6bpezMD.png - blender
http://i.imgur.com/EUMOmLX.png - SDK

Set “GENARATE_ALWAYS” before converting to j3o.

@normen and @eric said that this is your part. As they load BlenderKey.

Could you check it? You can take any texture and a Cube model for testing.

Hey @mifth

current setting for mipmaps is to generate as needed.
If I remember there was a discussion about it and the conclusion was to use this option by default in blender key.
In blender there is an option for the texture whether to generate mipmaps or not and current blender key setting takes that into account.
So you can either set the option to always generate in your blender key or check the proper option in your blend file.

And btw. sorry for my really late response :wink:

@Kaelthas said: Hey mifth

current setting for mipmaps is to generate as needed.
If I remember there was a discussion about it and the conclusion was to use this option by default in blender key.
In blender there is an option for the texture whether to generate mipmaps or not and current blender key setting takes that into account.
So you can either set the option to always generate in your blender key or check the proper option in your blend file.

And btw. sorry for my really late response :wink:

No problem about late responce.

But the isue is in SDK i guess. MipMap generation does not work at all. Even if i switch it on.
Check it here http://i.imgur.com/o4KLrWf.png

Just take any model with a texture, select ALWAYS_GENERATE, convert to j3o. And there will be no mipmaps. :frowning:

How to fix it in SDK? @normen or @eric or you should fix it somehow i guess.

If it doesn’t work in the SDK the importer is broken. I explained all this to your in the chat, why do you have to keep @mentioning me?