Blender Ogre XML install error

So i’m trying like said in docs, to install the Ogre XML Exporter into Blender. To install ogre, i found a topic who is more simple than the doc :

  • Installed Blender (64 bit version)
  • Closed Blender
  • Openned JME3
  • Tried to install OgreXML Exporter from tools>OgreXML>Install Blender Ogre XML
  • I choosed the correct directroy (C:\Programmes\Blender Fundation\Blender\2.7.0\scripts)
  • And i clicked the Install button, and strange error i got : C:\Program Files\Blender Fundation\Blender\2.7.0\scripts\ (Access Denied)

I’m using a legitimate (bought myself) version of Windows 7 Ultimate Edition 64 bits.
Config specs are :

  • Intel Core i7 3.7 Ghz CPU
  • ASUS NVIDIA GTX 650 TI DirectCU 2 2Gb GPU
  • 24 Gb RAM
  • 4 hard disks (2 IDE -> connected to an old extention card ; 1 SATA -> Connected directly to Motherboard second port ; 1 SATA -> Connected to motherboard first port -> It’s the system hard disk)
  • 2 DVD ROM Burner (One connected to motherboard SATA ports and the second is connected to my old IDE Extention card)
  • 1 ZIP 750 Connected to my old IDE extention card

I also tried to download separately the script from the internet. But when i install it into the scripts/addons directory, nothing new appears on Blender > File > Export.


Just import the .blend directly.

What ? What is .blend file ? How do i import that ? Where do i need to import ?

.blend is the file format that blender creates for its own files and you import it like any other model file.

Thank you i’ve found. It’s a bit complicated…

So we can consider this issue as solved.

Yes, game development isn’t easy.

You need to run jMonkey as an administrator. First right click on the jMonkey program, then click “Run as administrator”.

@jackcbrown89 said: You need to run jMonkey as an administrator. First right click on the jMonkey program, then click "Run as administrator".

Thats not a good idea, if you need to do this then your files and folders user rights are messed up.

If I’m not mistaken, you need to point it towards the scrip/addons directory. Don’t think your error is linked to that… just you won’t be able to enable it in blender later on otherwise.

1 Like

You need to

A. Run it as administrator
B. Install it in the directory: %appdata%\Blender Foundation\Blender(version number)\scripts\addons
C. Open Blender>File>User Preferences>Addons>Import-Export>Check the box next to OgreXML import & OgreXML Export

That worked for me! =D