Blender, OgreXML, JME3

Hello,

After searching for quite a while now I couldn’t find a solution to my problem. I created a model in Blender 2.65 and exported it with the blender2ogre(0.5.9) script. Everytime I try to load the model using Eclipse and JME3 (I think its the nightly build, I’ve got it from this site http://www.jmonkeyengine.com/nightly/ ) I get several warnings. They look like this:

13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: alpha_to_coverage
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: colour_write
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: depth_check
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: depth_func
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: depth_write
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: illumination_stage
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: light_clip_planes
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: light_scissor
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: normalise_normals
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: polygon_mode
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: scene_blend_op
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: shading
13.02.2013 11:10:59 com.jme3.scene.plugins.ogre.MaterialLoader readPassStatement
WARNUNG: Unsupported pass directive: transparent_sorting

JME3 shows my model, but several faces seem to be missing. Can somebody help me,please?

I think I need to add that the .material file has the same name as the .mesh.xml file. And my assetfolder is in the classpath of the project in Eclipse.

Thanks in advance!

Maybe a solution too simple, but have you checked the faces of your modell? Maybe they are not flipped in the right direction.

2 Likes

Thanks that was it! I never would have thought of this. Thank you so so much!

1 Like

No problem. We get this usually, when we or our designers forget to check that :slight_smile: