BLENDER to J3O File does not open if I generate tangents [BUG]


I have a model. If i convert a model to j3o, it opens ok. But if I generate tangents to it and save j3o it does not open.

Model (blend + j3o(without tangents)):




stable too? :stuck_out_tongue:

i have no stable :slight_smile:

You should if you want to get work done.

Do you have stable? Can you test it?

Works fine afaics, MonkeyZones models use tangents.

first of all try to use ogre mesh first. i have some problems with blend->j3o too.

btw be sure there are uv map (for tangents ones)

and it is propably same problem as here:

funny is that on earlier versions it worked

the problem is with JMP SceneComposer… This is its bug.

Model with tangents is loaded by JME ok… But there is the exception in JMP.

My model + tangent generator.

@normen , this is your part.

Learn to read a stack trace ^^

So why JME(with code) can load this model and JMP-Scenecomposer cannot?

Try to load it a second time. (in your code)

it loads in my code… but not in the SceneComposer.

If you go assetManager.loadModel(myModelName); twice in a row too?



Edit: Also how do you save/load/generate tangents on the model at all? It can all be done via the SDK and works fine for me (in stable that is).

Edit2: Nightly works as well, I can generate the tangents, save and load the model after:

If this bug is happening then you have bigger issues to worry about regarding that model …

@Momoko_Fan , @normen , I did for you video to show how this bug reveals. This is just a simple model with boxes objects.


@mifth as i said i have same bug as you. but in earlier versions of SDK it worked

i told from which version it have a bug, but i was only person having this bug so noone fixed it

So you use the blender importer, does it happen with the ogre importer too? Also, I’ll ask again, what happens if you load the j3o in code twice in a row, like



Btw theres no need to discern between SDK and “in code” here really, the SDK doesn’t do anything magical and if it fails then theres an issue with the model or the importer.

if i load twice in code it loads ok.

Ogre importer works ok.