Blending rate

Hi!



I have a question about blending:

I want to model a LED, and if i use AlphaState the model become too transparent, i almost can’t see (clear like glass, need not so transparent).

Tried to set the alpha value at materials, but that not working without AlphaState, so didn’t help…



I made some fonts before in c++, had problem with bitmap fonts when background changed the font color chaged because of blending, so i made trick with drawing the font first black, than the color i wanted.

I thought maybe drawing my model grey transparent first, than draw it with the color i want, but this makes double render time, and overcomplicated i think.



I saw in Lighwave3D you can set up transparency at material properties with a slide, i wonder how they made that :-o





I’m new to JME so it’s possible i missed a feature, or made something wrong, can you help me with this? :expressionless:



Thanks

the alpha values are between 0 and 1, so you'll have to play around a bit to figure out what value looks best for your material. how your material actually looks also depends on lighting.

also make sure you set the render queue for your LED to be the transparent queue.



i don't think it's a good idea to render your model in multiple passes only for obtaining transparency.


EagleHorn said:

I saw in Lighwave3D you can set up transparency at material properties with a slide, i wonder how they made that :-o


the slider would just adjust the alpha value. but some simple material editor for jme is not a bad idea.

Thanks a lot, got the problem:

I read in the forum that you need AlphaState for having material alpha effects, and i thought i have to add destination, and source values too, but i realized i only have to enable blend, and it’s having nice transparency now :wink:

THX :smiley:



yea the editor is a good idea.

I started to make it, edited the ParticleEditor, because i’m still noob in jme and java too :frowning:

i don’t know is it a problem or not (if yes hit me :|), else here is the shot from it:



have a small problem with the blending part, the back part doesn’t wanna be transparent (i hope you can see the shot)

and an other thing i noticed ambient, emissive, specular alpha doesn’t really modify anything, is that right, or it’s looks like a bug?



Decided to keep the tabs, because later maybe texturing can be added to test materials&textures or maybe multitexturing too. XD