Bone atachement node - not visible


i tried to attach 2 different spatial objects to a bone,

as i debug, the nodes are actualy well in the attachementNode children’s list

but they don’t show-up in the game as the anims are playing

can someone tell me what i do wrong?

rightHandAttachementNode=playerAnimController.getSkeleton().getBone("HandHolder.R").getAttachmentsNode(); Node grenade=tools.CreateGrenadeModel(Vector3f.ZERO); rightHandAttachementNode.attachChild(grenade); ...

public Node CreateGrenadeModel(Vector3f origin ) { <<<<<<<<<<<<<<<<<<<<<<<<<<<< this objects usualy shows up in the scene
Node grenadeModel = (Node) DataManager.LoadModel("Models/Grenade/Grenade.j3o");
return grenadeModel;


i could not use the attachement bone, could be a bug

so i tried to use a controller to bind the atached object to the bone itself

as a result, the bone follows the main player, but is does not add the bone transform from the anim

plz help me buuuuuuuu :frowning:

@Override protected void controlUpdate(float tpf) { attachement.setLocalTransform( bone.getCombinedTransform( playerControl.getPlayerSpatial().getLocalTranslation(), playerControl.getPlayerSpatial().getLocalRotation()) ); }

Are you still using alpha4? You should update to beta1