Broken platform reference

I have problem.

I just installed JM3sdk and update everything (nightly version of course) and i don’t change any thing and it does not work… ;-(

I’m sorry for problem but it’s important for me because i write project on my university with Yours Engine.







I try start the project with two options windows.exe or android 2.2 and with both the are the same problem.



I’m really thankful for help.

And I think it’s not my the last one question because I just start my adventure with JM3 and i think it is the good choose.



edit:

Ok, my mistake. I have jdk install in path with " ". I don’t know but if you can set the path in “” and code it in utf-8 or unicode it can solve problems many people :wink: i change the path but for the future can you change it??



edit2:

I change the path but it don’t solve my problem.

The window java platform manager is empty… i don’t know why… I try tree times add my jdk and it said mi



exists??

Does installing NetBeans on your computer work? It looks like your windows/java installation is pretty messed up.

i had the same issue last night, i noticed i had multiple older versions of java installed. first i uninstalled all older versions of java and updated to the newest version and rebooted, next i uninstalled jMonkeyPlatform then reinstalled it and updated to nightly version, that solved my issue without even having to change the path locations.

hope that helps you.

The plugins are enabled properly when you start the jmp? A simple solution to it would be reinstalling it again xD, and taking care to not install wrong plugins.

I’m having the same problem and have now tried it on both OS X and Windows. OS X only has one JDK installed and Windows only has x86 and x64 versions.



No matter what I do, I can’t get past the “Add Platform” screen (it always remains empty) :frowning:

Hm, strange… No idea why that might be so, I just installed jMP freshly on my windows PC… oO

To compound the weird factor, the standard version of NetBeans picks up the platforms fine on both computers! It may be worth noting that jMP and NB have two different Java Platforms windows…



NetBeans

http://i.imgur.com/6ydlv.png



jMP

http://i.imgur.com/uFYfp.png

The strange thing is that none of the base platform plugins have been updated lately… What happens when you specify the JDK location in jmonkeyplatform.conf?

Uh btw, you guys updated all the way, right? You have to update and restart the app like 3 times or so to get all updates.

Edit: Just did a fresh install on my Mac as well, cannot reproduce this, sorry…

This might be due to a bug in the jME2 loader plugin, try uninstalling that if you have it installed for now.

Ok thank you for helping. I reinstall Jmonkeyplatform and it work now.



:smiley:

go to

tools → plugins → Installed → JME2Loader and Deactivate it. It works for me