Build and Compile - The jMonkeyEngine3 SDK based on netbeans


I have just downloaded JMonkeyEngine SDK from the github. I tried to build and compile it with Netbean. But I encountered following error, I assume it will be easy for you, for I am new to Java and Netbean, I have no idea what is the causes and solution. Need your help.

Error Message:
ant -f C:\Users\kiantat.wong\sdk run
C:\Program Files (x86)\NetBeans 8.2\harness\suite.xml:130: Cannot open C:\Users\kiantat.wong\sdk\jme3-core-baselibs\nbproject\project.xml
BUILD FAILED (total time: 0 seconds)

KT Wong


I built it on Window 10. Can you help ?

Can anyone please help me?

Hi. I have never done this so am not able to offer much, but first, chill. You won’t always get an instant response, no need to keep bumping it.

Did you follow these instructions to the word?

Cannot open C:\Users\kiantat.wong\sdk\jme3-core-baselibs\nbproject\project.xml

This looks like it isn’t finding the file project.xml or some other issue with the file?

More importantly - you mention you are new to java (raises some questions in itself but more power to you) and netbeans - is there any reason you can’t just download


from the github? It includes a version of netbeans specifically for JME and will save you some hastle.

Frankly say, I just learn this for hobby, not for commercial and even not for academic purpose. I am a mobile app programmer, just want to learn something new in free time, I had done a very simple 3D game using C++ and OpenGL to complete degree, but a decade ago. Now, I try to pick up Java as my new tool to develop mobile app. Expect to get some fun in developing mobile game. I have installed the exe, but as you know without knowing the full code how it run, it is no fun as a programmer. Really need your help to build and compile it from source code, please…

I have just checked the folder, the project.xml is lost in netbeans. is this the main reason to made it run? I never used netbean IDE.

I tried again to download the SDK version from Releases · jMonkeyEngine/sdk · GitHub. Still same, the same error again. How?

Without the project.xml, ant (the build tool being used here) can’t compile your code. Make sure the file exists and that it’s at the place where the error message says ant is looking for it.

The Correct Way to Build and Run JMonkeyEngine SDK

  1. Download Releases · jMonkeyEngine/sdk · GitHub (Source code)
  2. Run cmd to execute gradlew.bat with this command ‘gradlew.bat buildSdk’
  3. Comment the following lines in build.gradle
    // optlibs dep(“org.jmonkeyengine:jme3-jbullet:$jmeEngineVersion”, true, true)
    // optlibs dep(“org.jmonkeyengine:jme3-jogl:$jmeEngineVersion”, true, true)
    //optlibs dep(“org.jmonkeyengine:jme3-android:$jmeEngineVersion”, true, true)
    //optlibs dep(“org.jmonkeyengine:jme3-ios:$jmeEngineVersion”, true, true)
    //optlibs dep(“org.jmonkeyengine:jme3-android-native:$jmeEngineVersion”, true, true)
    // optlibs dep(“org.jmonkeyengine:jme3-bullet-native-android:$jmeEngineVersion”, true, true)
    //testdatalibs dep(“org.jmonkeyengine:jme3-testdata:$jmeEngineVersion”, false, false)
    //examplelibs dep(“org.jmonkeyengine:jme3-examples:$jmeEngineVersion”, false, true)
  4. After finishing build, download Netbeans, Open it with Netbeans to debug it in IDE.