Can’t rename in the SceneExplorer Window

I can’t rename the Name of root scene node or the terrain node, no matter how I try, when i reopen the *.j3o file I find that names are as they were before. Is this an issue?

How do you rename it?

I tried both, 1.using F2 and 2.right click > rename > ok.

I have another question, Why the physics debug shape of terrain doesn’t show up?

Hi guys, I’m getting this issue too; any reason why the change doesn’t get saved when you attempt to rename in the scene explorer?

Yes there is a reason I guess ^^

1 Like

:slight_smile: Perhaps I should reword the question then, “When I rename a spatial in the scene explorer the change isn’t being saved, why is this happening?”

Because the save button isn’t enabled, its a known issue. :roll:

1 Like

Ahh, I see! As long as I’m not just going crazy!

Thanks for the swift response ^^


@normen said:
Because the save button isn't enabled, its a known issue. :roll:

I thought this thread is being ignored. :P

Well, I solved this by editing some other field …

If I rename a node/spatial/etc and just the rename is the modification, then it’s not updated.

If I rename and also change a local translation, rotation, etc, then the scene is saved correctly (also the name)

So I think that the problem is maybe a variable or something that determines if something has changed and enable the saving. Rename is not enabling it but it’s being saved if another event turns on the save.