Cannot export skeleton.xml from blender


I have a problem exporting my character from blender to jmonkey through ogre. Importing the character and its texture (uv-mapped) works great. But importing animations does’nt seem to work.

When I export the character, I do net get the skeleton.xml. I only get Cylinder.mesh.xml, Material.material, monkey3.png, and MonkeyAnim.scene.

I have created a track in the nla-editor, I have tried all the different options for exporting and I still won’t get the skeleton.xml. But it exports “correctly” because I can load my Monkey character in jmonkey with its texture, but I cannot se any skeleton.xml.

I have looked at the documentation for exporting in blender but I do not know what I’ve missed.

Providing you have created the track and added the action strips to it, not sure. However I’d be happy to look at the blend for you and find out why.

I went into actioneditor and created animation, and then to the nla-editor and my animation is there and I can play it and it works so far. But what do you mean by added action strips?

Of course, how do we do that? :stuck_out_tongue:

In the NLA editor, just add > add action strip > your animation. Guessing thats done though when you created the track.

I’m guessing this isnt a popular site but I’d just upload the blend to and post the link here, its quick and easy site to use. If you have any other way you prefer thats fine too.

Ok I just open the nla-editor and pressing the “snowball” and the animation is there.

I uploaded the blend file here,

Just tell me if you need something more like the png file for material or anything.

Hi my friend
Did you add armature modifier to your model ?
If not ,then select your model in object mode then go to Modifier tab in properties panel and add Armature Modifier .

1 Like

Yeah it’s not added, exports correctly when you ad the armature modifier

Ok thank you, but whenn I add the armature modifier, should the mesh or the bones the selected?

And one more thing, in the blend file I gave you, the armature modifer which I have in the mesh, is applied, because if I don’t apply, I get export error.

So should I add another one or?


I seem to have mixed up 2 blender files, I don’t remember if the modifer was applied in the blend file I uploaded.

eh… uhm,

When I do this I never apply the modifier. I’m no expert so anyone correct me if I’m wrong, but applying the modifier just changes the shape of the mesh according to the animation which is a problem. I always simply add the modifier and export to ogre with no problems/

You apply it to the mesh. Select it, add armature modifier, then when you see the modifier come up you will see a box called “Object” that is empty, click here and select your armature

I think it was applied in the one you uploaded, cos the model wasnt in any of the common poses for animating

edit: Like i said it worked for me when i added the modifier, but just throwing this in there: not sure ogre supports ik controllers?

I do not have IK in this one. I checked now and I already have an armture modifier added to the mesh (not applied), I thin I added it when I started rigging the bones. But in this file:

it is not applied, and I get error when I export, could you have a look at this one?


I have an armature modifier but I get an error in blender when exporting if it is not applied. Here is the last one I made and I don’t understand what’s wrong.

Both files export for me without applying, no changes made. I get a ,mesh.xml and an .skeleton.xml and blender only gives me 2 warnings which I ignore.

What error are you getting?

Ok that’s weird, I’m using blender 2.69, and you?

This is the stack trace:

It must be something wring with my ogre exporter or something like that I guess

Oh… probably should have started with this then. I’m using 2.73a but I also have 2.69 installed; just tried it and works fine for me.

Here is my exporter

\Blender 2.6.9\2.69\scripts\addons is the location I have it in

You can try that if you’d like

Ok I replaced my exporter with yours but it is still the same… I have everything checked on the left side except for “only animated bones”, and when I export i select the mesh, but I have tried with the armature too but I won’t get the skeleton… And in the top bar there is an ogre checkbox, which I have checked, but could I have missed something?

I do not have the top ogre box ticked (not sure it’ll matter)

THANK YOU NOW IT WORKS!!! I changed to the export settings you have and now I get the damn skeleton xml!!! Thank you for all your help, really nice of you! :smiley:

I checked your model . it works . Happy that you could solve the problem.
also for more info you can check

Thank you! I will have a look at it!