Cannot locate the Ogre File

Alright, hey!



I’m having some trouble importing a model that I made in Maya 2012. I exported with OgreMAX to a mesh.xml and material file. And then I copied it in to the Assets model folder like I’m assuming I’m supposed to do. Then after that when I try to convert it to J3o, it can’t find the file…



Here is the message I get:



Cannot locate resource: Models/ship.mesh.xml

Trying to save asset that has not been loaded before or does not support saving!

Could not locate saved file.




I’m clueless of what to do :frowning:

Make sure the model and its material are in the same location and with the same name.

e.g.: mymodel.mesh.xml mymodel.material

I’ve tried that now (actually I think I might have tried it earlier) but that didn’t work :frowning:

It just gives me the same message.

Could it be where I put them? Right now I put them in Ship/Project Assets/Models

(Ship is the project name)

This is weird.

The tutorial says:

Activate the following exporter settings:
Copy Textures: YES
Rendering Materials: YES
Flip Axis: YES
Require Materials: YES
Skeleton name follows mesh: YES

But I never get those options when exporting, could that be the problem perhaps?

Also, something that is odd is that it doesn't export to XML just .mesh. And I can't change it to .xml?

Try add .xml to the .mesh file as you said.

e.g.: mymodel.mesh mymodel.mesh.xml



Does it work?

No, that doesn’t work either…



I was thinking that it was the wrong exporter or something. But JMonkeyPlatform recognize them as Ogre files and displays them with the Ogre icon so that can’t be it.