Can't activate plug-ins

I can’t activate any plug-ins for jMP, not even Java, it doesnt give mr an error it just sayd couldnt activate so-and-so plugin and gives me the directory. I cant use jMP at all.

If you have to activate them then they have to be deactivated at some point? Maybe when you get the warning on start that a JDK is needed? Anyway, very bad help request post, you dont even say what OS you are on :roll:

Sorry :P. I’m on Windows 7 Home 64-bit. My specs are:

AMD Phenom X4 925 (quad core)

ATI Radeon HD 4350 512MB


1TB hard drive (though i dont see how that could help)

I have uninstalled and reinstalled jME 3 or 4 times now, and most plugins, including Java, are disabled. When I try to enable them I get no error, it just says “couldn’t initiate (so and so) plugin” and gives me tyhe directory of the plugin.

PS: I’m not in an admin account, but jME isn’t installed in a read-only directory, its in a folder directly on the local disk. (C:jMonkeyEngine)

Are you sure you have a JDK installed, what version is it?

I had JDK 1.7 installed, but because it’s beta, i decided to install JDK 1.6u25 as well. Even when I switch JDKs it doesnt work. However, I installed it on my Windows XP on an Admin account and it worked perfectly, so I’m gonna try installing jME on a Windows 7 Admin.

I guess you don’t have Java7 on the XP machine? You can specify the JDK being used in the etc/jmonkeyplatform.conf file in the jMonkeyPlatform program folder.

No, I don’t have JDK 7 on my XP compy. However, it’s video card is old as the hills, and is glitchy with OpenGL 2 so I can’t test my project. I’m installing jME off an admin account on my Windows 7 in a few.

First try pointing at the java6 jdk so that jmp is started using that. Also OpenJDK does not work as good, use Oracles.

I have already tried both JDKs (6 and 7) and I am using Oracle’s JDK as well. I think it’s just that I installed it on a non-admin account, so it can’t access certain features in read-only directories. Hopefully I don’t have to be on an Admin account to work on my project! Maybe you could add a way where plugins and stuff can be installed to a custom directory? I’ll figure something out. Thanks for all the help!

Its all installed in user accessible directories and it works on user accounts in windows, idk whats wrong on your machine.

Well, I installed it on my Win7 Admin account, and it worked perfectly, but I can’t use this account because it is my parents. So I’ll just use my WinXP computer instead, which I upgraded to NVIDIA GeForce 8400GS. Maybe I can fix it on my other computer later.