Can't import any models at all into jMonkey

Not much else to say… I simply can’t import a single model to jMonkey. Every model I try importing says “Model cannot be loaded.”

I even tried importing models from “HelloCollision” from the tutorial and got the same error, yet it works in the .zip that the tutorial came with.

I will be extremely happy if anybody can help me with this.

Also, a bonus problem-- The Ogre exporter doesn’t work for me. I finally got it listed as an option in Blender, but then I get this list of errors when I actually try exporting: http://i.imgur.com/HmXCytu.png

However, if I could just import .blend models, I wouldn’t even need the Ogre exporter. And honestly, everything relating to Ogre is just too confusing for me. (For example, the Ogre3D download doesn’t come with a GUI and I have no idea how to do anything with it.)

So tl;dr, how do I fix this problem and import .blend/.obj models to my jMonkey project? Thanks.

Not sure about your import issue, but I had some problems with exporting Ogre from Blender with the ogre exporter that came with jME. Solved it by downloading the latest version of the plugin, I think this is it:
https://code.google.com/p/blender2ogre/

I got the Blender-to-Ogre export working finally. I installed the newest version in the link you posted, and changed from Blender 2.61 to 2.63. Thanks.

Now all that’s left is figuring out how to import things into jMonkey…

EDIT: I just imported the cube that I exported into an Ogre file and it worked! I think my problems are all solved.
Thanks again, Tryder!

Well, it lasted for a few hours, but now Blender’s giving me errors again: http://i.imgur.com/JQJ3Wr4.png

From in Blender click the “Window” menu at the top of the screen and select “Toggle System Console.” This will display Blender’s console output. One of the first things printed to the console, probably the first, should be “found bundled python…”

If it did not find bundled python then it’s using whatever version of Python that you have installed on your system which may be incompatible, I believe Blender is using Python 3.0 now. Can’t remember which one, but at one point there was a version of Blender that went ahead and used installed Python before checking for bundled Python and that created problems with incompatible versions of Python.

Are you using the 3.1 git build or the 3.0 sdk?