Can't import models?

Hello!



I just started using jMonkey today and already ran into a problem! :smiley: (woohoo?). I made a simple model in blender (literally just a square) and saved it. But when I click the upload button nothing happens. I do have the project selected and the import models button is lit up and not faded but whenever I click it, nothing happens. Can somebody help please! D:

do you press the light icon in the scene explorer? Models imported from blender need a light, unless you apply an unshaded.j3md material to them

What’s the light icon? Is it in the jMonkey SDK or in blender?



EDIT: I just tried the same exact thing as I did last time… but it worked! :smiley: Except that I can’t import the file I was trying to. What does the extension need to be? If it’s a .xml how do I get that to work, because it’s not an option. :confused:

JME3 can import .blend files (drop them in assets, right click->convert to j3o)…however depending on your version of blender you may need the nightly SDK as they made a big change to their internal format with 2.63.